Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
[SOLVED] Re: [opensuse] system not booting
Am 26.01.2016 um 13:55 schrieb Benjamin Draxlbauer:

Gesendet: Dienstag, 26. Januar 2016 um 12:53 Uhr
Von: "Bob Williams"<linux@xxxxxxxxxxxxxxx>
Betreff: Re: Aw: Re: Re: [opensuse] system not booting
On 26/01/16 11:13, Benjamin Draxlbauer wrote:
Gesendet: Dienstag, 26. Januar 2016 um 11:37 Uhr
Von: "Stanislav Baiduzhyi"<baiduzhyi.devel@xxxxxxxxx>
An: opensuse<opensuse@xxxxxxxxxxxx>
Betreff: Re: Re: [opensuse] system not booting
On Tue, Jan 26, 2016 at 11:13 AM, Benjamin Draxlbauer<Benjamin10@xxxxxx> wrote:
Thanks for the hint…Where should i add this line? I am not familiar on this
type of stuff…
you can try that from rescue cd, gparted-live-cd is my personal
favourite, and do something like this in terminal:
sudo su - root
mkdir /mnt/sda3
mount -t btrfs -o clear_cache /dev/sda3 /mnt/sda3

if that command succeeds then clearing cache helped and you can try
rebooting to your main system. Otherwise you have different problem,
maybe someone else will be able to advice something.
To unsubscribe, e-mail:opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail:opensuse+owner@xxxxxxxxxxxx

Okay, i tried it within a terminal in ubunut which is the second system i am
running on my laptop…

sudo mount -t btrfs -o clear_cache /dev/sda3 /mnt/sda3
mount: Falscher Dateisystemtyp, ungültige Optionen, der
Superblock von /dev/sda3 ist beschädigt, fehlende
Kodierungsseite oder ein anderer Fehler
Manchmal liefert das Systemprotokoll wertvolle Informationen,
versuchen Sie »dmesg | tail« oder so

and dmesg tells the following:

dmesg | tail
[ 514.164113] parent transid verify failed on 35295068160 wanted
41939771539587072 found 25424
[ 514.164117] BTRFS: failed to read chunk root on sda3
[ 514.182238] BTRFS: open_ctree failed
[ 593.703113] BTRFS info (device sda3): force clearing of disk cache
[ 593.703118] BTRFS info (device sda3): disk space caching is enabled
[ 593.703120] BTRFS: has skinny extents
[ 593.711602] parent transid verify failed on 35295068160 wanted
41939771539587072 found 25424
[ 593.723735] parent transid verify failed on 35295068160 wanted
41939771539587072 found 25424
[ 593.723742] BTRFS: failed to read chunk root on sda3
[ 593.741048] BTRFS: open_ctree failed

Almost the same as in my first mail…Any suggestions? This looks quite
critical…and…i don't have a recent update!!!

You haven't mentioned which version of opensuse you are running, and
more importantly, which kernel.
You'll probably get more help on thelinux-btrfs@xxxxxxxxxxxxxxx list.
First question they'll ask is are you running an up to date kernel and
an up to date version of btrfs-progs.

Bob Williams
System: Linux 4.1.13-5-default
Distro: openSUSE 42.1 (x86_64) with KDE Development Platform: 4.14.10
Thanks for the hint…
Here are my specs:

System: Opensuse 42.1 Leap
KDE Plasma: 5.4.3
Qt: 5.5.1
Kernel: 4.3.0-2-default

unfortunately I have no access to my system, so I do not know which versions of
btrfs-progs i have. But my system is up to date (lateste update 2 days ago).
(sorry Bob for sending you a private mail…was a mistake!)
I do not know why, but it seems, that something has rotten my btrfs filesystem of my root partition (sda3)… I could solve the issue by running:

I did:

|btrfs-zero-log /dev/sda5|

This made the partition mountable again.

Thanks for hints!
Best, Benjamin!
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups