Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] disabling KMS (nomodset)
jdd composed on 2016-01-04 23:19 (UTC+0100):

I didn't ask for nvidia driver. I just enabled nvidia repository

IMO by enabling the optional repo you asked for the driver it provides. Maybe
your next steps should be to disable that repo, uninstall the nvidia driver,
remove the xorg.conf its installation created, remove nomodeset from cmdline,
and see how the nouveau driver works for you. Nouveau works as good as it
needs to for me. I've never installed any proprietary driver on any of my own
Linux systems. FOSS and the hardware it supports rulez! :-)

I'm surprised it loads. Or, maybe it doesn't, and that's the "crash" you
experience. What does Xorg.0.log look like when nomodeset is omitted from
cmdline.

no chance to see them as it crashes

No chance is not true. Boot with 3 on cmdline, then login as root on a vtty.
Then you can reach and preserve both Xorg.0.log and Xorg.0.log.old for
sharing and finding the (EE) messages that tell what has gone wrong and the
(WW) messages pointing to potential trouble.

it booted for some days before the problem come

Caused by updates is not nice. :-(
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups