Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] NetworkManager in multi-user target
On 01/02/2016 09:11 AM, Patrick Shanahan wrote:

But now NM requests root pw before allowing network connection. Is there
a work-a-round for that also. tks

Ooh! That's quite some change since I last tried this.

So I did some experimenting. Here's what I did:

I installed "NetworkManager-gnome" and "polkit-gnome".

I logged into icewm. There, I ran two commands:
--- clip here ---
/usr/lib/polkit-gnome-authentication-agent-1 &
nm-applet &
--- clip here ---

That gave me a NetworkManager icon on the icewm panel.

Using that applet, I edited the connection. This did ask for the root password.

While editing the connection, I went to the security settings, where there was a place that I could enter the WiFi key.

I entered it. At the end of that line there is a small graphic. Clicking that graphic, there was a choice between:

save password for this user only (the default)
save password for all users
prompt for password every time

That's not the exact wording, and maybe not the exact order. It was about the network wifi key. So I switched to save the password for all users.

After that, everything is fine with no root prompts for connection, and it works also in multi-user mode.

That option on where to save the password does not seem to exist in the KDE plasmoid. That's why I tried the gnome applet. In my previous experience, the password (key) for a shared connection was always stored for all users (in "/etc/NetworkManager/system-connections").

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups