Mailinglist Archive: opensuse (911 mails)

< Previous Next >
Re: [opensuse] puzzle of the week: why was my eth1 renamed ibft0 ?
17.12.2015 13:05, Per Jessen пишет:
Per Jessen wrote:

Andrei Borzenkov wrote:

I did not study code enough to check what depends on fixed name.
May be it is more simple to accept this?

Yes, quite likely. I'm trying to think of what issues it might cause.
Seems like it might play merry hell with wicked, yast network config
and the firewall.

I think I'll need some help with this :-)

I want to set MTU 9000 for eth1, so at first I
updated /etc/sysconfig/network/ifcfg-eth1 by hand, adding MTU=9000.
This didn't change anything. Then I rebuilt the initrd, still no
effect, mtu remains at 1500.
I though it might work if I copied ifcfg-eth1 to ifcfg-ibft0 and rebuilt
the initrd, but still no joy.

Manually setting it works:

# ip link set mtu 9000 dev ibft0
# ip addr
3: ibft0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc pfifo_fast
state UP group default qlen 1000
link/ether 00:30:48:90:80:d1 brd ff:ff:ff:ff:ff:ff
inet 10.42.8.4/21 brd 10.42.15.255 scope global ibft0
valid_lft forever preferred_lft forever
inet6 fe80::230:48ff:fe90:80d1/64 scope link
valid_lft forever preferred_lft forever


wicked is quite slow in starting (31sec) and also reports:

Ignoring ibft0 config compat:suse:/etc/sysconfig/network/ifcfg-ibft0
because of higher prio config

What does that mean?



wicked understands iBFT as well and uses it as one of configuration
sources. It has higher priority than manual configuration.

Can you configure MTU in firmware used for booting?
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups