Mailinglist Archive: opensuse (911 mails)

< Previous Next >
Re: [opensuse] Systemtray Icons in plasma 5?
Am 15.12.2015 um 08:57 schrieb Benjamin:
Am 14.12.2015 um 17:52 schrieb Gustav Degreef:
On 12/14/2015 01:48 PM, Benjamin wrote:
Am 14.12.2015 um 12:06 schrieb Gustav Degreef:
On 12/14/2015 11:28 AM, Benjamin wrote:
Am 14.12.2015 um 10:27 schrieb Gustav Degreef:
On 12/13/2015 08:27 PM, Benjamin wrote:
Ahh sorry forgot to mention some specs:
was a fresh install of 42.1 Leap
KDE: 5.4.3
Qt: 5.5.0
Kernel: 4.3.0-2-default
64bit
Best, Benjamin!

Am 13.12.2015 um 19:33 schrieb Gustav Degreef:
On 12/13/2015 12:12 PM, Benjamin wrote:
Hi everyone!
I do have some troubles with regard to plasma 5 and the systray
icons:
Thunderbird, Firefox, Tomboy and other progs are not showing up
anymore in the systray.
snip
Thanks for the info gustav (and sorry for sendig you a privat
mail…was a mistake).
…No it was a fresh install of 42.1. Leap

No problem, let's see if I can help clarify the issue a bit further.
If you have an optimus laptop, you have 2 graphic chipsets; I assume one
Intel and the other nVidia. With optius hardware ALL of the graphical
output first goes through the intel (on board) chip, and then, if you
have the drivers set up properly it goes through the nvidia card. In
opensuse, the only way (as far as I have been able to determine) to get
the nvidia card to work is by using Bumblebee - with either the nVidia
driver or with the nouveau driver. Without Bumblebee, the nVidia card
is not being accessed, so only your primary (intel?) card is providing
graphical output after your initial install.

1. Have you determined which specific graphic chipsets your machine has?
2. Did you install Bumblebee?
3. Did you ever have a functional Desktop with Leap? That is where the
icons were showing up?
4. How did your system function right after the fresh install, before
you did anything else?
Gustav.

thanks for the reply!
Actually my Desktop is running smoothly with the bumblebee setup,
where I normally use the intel 5000 chipset of my laptop the nvidia
card is switched of by the bumblebee by default. So there seems to me
no problem with regard graphics…Only the Icons of (i think but i
am not sure) an older gtk/qt version are not showing up in the
systemtray. For exapmle of tomboy, thunderbird or firefoy....Newert
Systemtray icons (clementine, owncloud) are showing up. Do you think
that has to do with the graphical setup?

Thanks, Benjamin.

Are you really talking about the System Tray, or the Task Manager?
Icons (launchers) for Thunderbird, etc can be added to the left side of
the panel, immediately to the right of the Activities and Virtual
Desktop area. Is that what you are talking about, or do you mean that
when these applications are opnened, that they do not show up on the
taskbar?

If you are talking about the taskbar, I am not sure if the behavior is
due to your graphics setup or not. But I have had a great deal of
problems with Plasma 5 (on an optimus laptop) and I recently read this
which I found helpful:

https://wiki.archlinux.org/index.php/KDE#Intel

“Intel
If you use 3D-accelerated composition with Intel, you might find that
the Plasma panel and other applications don't refresh properly (stay
frozen). Some Intel drivers have problems with EGL. Try to set Plasma
5's OpenGL interface setting to GLX instead (in System Settings under
Display and Monitor -> Compositor. If that does not work, see Intel
graphics SNA issues for alternative solutions.”

HTH, Gustav


Hmm okay. I meant the icons, which appear in the systray when you minimize tb or ff. (Where the other icons like volume etc are). Okay i never had too much of a problem with the optimus stuff…I mainly used Smithfarms tutorials
http://smithfarm-thebrain.blogspot.cz/2013/10/opensuse-131-nvidia-optimus-bumblebee.html
of course its old now but worked like a charm on 13.1. and 13.2 for about 3 years…lets see if it works on 42.1. ;)

Best, Benjamin.
Some news about the case ;)

I tried to delete my old (from 13.1, 13.2. etc) .kde and .kde4 folders and install plasma anew…But that didn solve my troubles with the icons. But i have small workaround…when i disable the desktop effects (Alt+Shift+F12) and enable them again, everything works fine…this means to me, it is not a problem with graphics (i tried it with bumblee and nvidia-bumblebee; now I am a little testing around with different compositing stuff …OpenGl etc). The only thing is, that old icons (programs using older gtk/qt versions) have an ugly black background behaind the icons, but this is just a "optical" point does not interrupt my workflow ;) Maybe it is a bug…

Best, Benjamin.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >