Mailinglist Archive: opensuse (911 mails)

< Previous Next >
Re: [opensuse] Re: Re: openSuSE 13.1 gtk_file_chooser_dialog_new triggers org.gtk.Private.GPhoto2VolumeMonitor Error?
On 12/10/2015 04:08 AM, Marcus Meissner wrote:
On Wed, Dec 09, 2015 at 09:15:09AM +0100, Yamaban wrote:
On Wed, 9 Dec 2015 07:34, David C. Rankin wrote:
On 12/09/2015 12:09 AM, David C. Rankin wrote:
Thank you,

If I remove:

/usr/lib/gvfs/gvfs-gphoto2-volume-monitor
/usr/share/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service

won't that mess up gphoto2 ability to connect/download info from phones,
cameras, etc?


How is this service ever supposed to work to begin with?
/usr/lib/gvfs/gvfs-gphoto2-volume-monitor is a file with
permissions set to '0000':

$ ls -al /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
---------- 1 root root 94296 Aug 26 2014
/usr/lib/gvfs/gvfs-gphoto2-volume-monitor

Ok, that is wrong. The rights should show: "-rwxr-xr-x"

Try a "sudo chmod a+rx,u+w /usr/lib/gvfs/gvfs-gphoto2-volume-monitor"
first and look for a repeat of the errormessage after a relogin.

(Re-Login bacause of underlaying troubles in dbus, such error-recovery
is seldom successfull in active user session)

This likely was an intentional change, to allow other gphoto2 apps that do
not use gphoto2 to work and not to block.

Ciao, Marcus


Yambam, Marcus,

Thanks for your help. If I understand the state of the discussion, we have isolated (1) a workaround and, (2) several open/unresolved issues regarding why this error is being thrown to begin with:

(1) removing the following 2 files will prevent the error from being thrown, but also remove/eliminate media autodetect for import by gphoto apps; and

(2)
(a) gvfs root cause of the error -- why is it generated?;
(b) permissions of '0000' on /usr/lib/gvfs/gvfs-gphoto2-volume-monitor

Is this the case on 13.2 and Leap? If so, do we need to open a bug so this can be worked/fixed? If so, what component to open the bug under? (gvfs, dbus, etc.?)

<< For those interested in testing on 13.2 or Leap: >>

You can compile/test on your system by compiling the following. You will need the appropriate version of either:

gtk2-devel and libgtk-2_0-0
or
gtk3-devel and libgtk-3_0-3

along with 'pkg-config' installed.

The compile string for GTK+2 and GTK+3 using pkg-config are shown below. (all one line, '\' is simply a line continuation. You can copy/paste both linees, including the line continuation into your terminal after saving the file in the proper filename):

GTK+2:

gcc -Wall -Wextra -O3 -o filechooser filechooser.c \
$(pkg-config --cflags --libs gtk+-2.0)

GTK+3:

gcc -Wall -Wextra -O3 -o filechooser filechooser.c \
$(pkg-config --cflags --libs gtk+-3.0)

(ignore: -Wdeprecated-declarations warning for STOCK items with GTK+3)

Just save the following in a text file, say filechooser.c, open konsole, gnome-terminal or xterm, and issue the appropriate compile string for gcc:

#include <gtk/gtk.h>

int main( int argc,
char *argv[] )
{
GtkWidget *dialog;

gtk_init (&argc, &argv);

/* Create a new file chooser widget */
dialog = gtk_file_chooser_dialog_new ("Please select a file for editing",
NULL,
GTK_FILE_CHOOSER_ACTION_OPEN,
GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL,
GTK_STOCK_OPEN, GTK_RESPONSE_ACCEPT,
NULL);

if (gtk_dialog_run (GTK_DIALOG (dialog)) == GTK_RESPONSE_ACCEPT)
{
char *filename;
filename = gtk_file_chooser_get_filename (GTK_FILE_CHOOSER (dialog));
g_print ("\n filename: %s\n\n", filename);
g_free (filename);
}
gtk_widget_destroy (dialog);

return 0;
}

Then just run the resulting ./filechooser executable and look for the error... If you receive the same error on 13.2 or Leap, let me know and I can include that information with the bug report.

--
David C. Rankin, J.D.,P.E.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >