Mailinglist Archive: opensuse (911 mails)

< Previous Next >
RE: Re: [opensuse] Some Leap Experiences and Issues


-----Ursprüngliche Nachricht-----
Von: Lew Wolfgang
Gesendet: So. 06.12.2015 21:04
An: opensuse@xxxxxxxxxxxx
Betreff: Re: [opensuse] Some Leap Experiences and Issues

On 12/06/2015 11:09 AM, Andrei Borzenkov wrote:
06.12.2015 21:42, Lew Wolfgang пишет:
No problem, I say, I'll just boot into bash by adding init=/bin/bash on
the Grub "linux" line. Great, that works and I've got a command .
But, the shell seemed to be running as an unpriviledged user! It would
say "/usr/sbin/userdel appears to require root authorization, which you
don't have", or some-such. It wouldn't let me do anything that required
root authorization! I've didn't try to boot into "single-user"
because of
bad experiences I've had with a certain initialization system.

That's due to missing /sbin and /usr/sbin in PATH. Just set them or use
full path.
But bash was finding the executables in /usr/sbin, it just wouldn't run
them.
No, it does not find them. See "type command_not_found_handle".

Just tried it again. I added init-=/bin/bash to the grub2 "linux" line It
then
boots into a bash shell.

I then noticed that / is mount ro at this point. This is different. So a
mount -o remount,rw / fixed that.

Then typing just "useradd" returns:

Absolute path to 'useradd' is '/usr/sbin/useradd', so running it may require
superuser privileges (eg. root).

So I then tried "sudo useradd" and that worked. Also different from 13.1--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >