Mailinglist Archive: opensuse (729 mails)

< Previous Next >
[opensuse] libKF5WindowSystem5 devel package?
I would like to code on the LXQt project.
So I checked out their code and walked my way through the cmake.
Currently I am trying to compile lxqt-config.
Running cmake and seeing what libs I need to install, so far I installed:

libqt5widgets-devel
libQt5DBus-devel
libQt5xml-devel
libQt5concurrent-devel
libqt5-qtx11extras-devel
libqt5-linguist-devel
liblxqt-devel

Now cmake is asking for FindKF5WindowSystem, exact message:

CMake Error at /usr/share/cmake/lxqt/lxqt_use.cmake:62 (find_package):
By not providing "FindKF5WindowSystem.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"KF5WindowSystem", but CMake did not find one.

Could not find a package configuration file provided by "KF5WindowSystem"
with any of the following names:

KF5WindowSystemConfig.cmake
kf5windowsystem-config.cmake


zypper told me libKF5WindowSystem5 is already installed and i dont see a libKF5WindowSystem5-devel package for this one, no idea why.

Why is there not devel package for this? Am I missing something here? :-)

--
Michael
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups