Mailinglist Archive: opensuse (1620 mails)

< Previous Next >
Re: [opensuse] Software installer fails to install rpm package
Il 28/11/2014 14:16, Anton Aylward ha scritto:
On 11/28/2014 10:37 AM, Marco Calistri wrote:

But where is the problem then?

Ultimately, your problem is that you are using a GUI to do a CLI
job.

Its not that there aren't GUI package managers, there are, but
that's not what you are using. You are using a file manager, and that
is not a package manager.

File managers are limited in capability but make use of external
programs that are involved when you click on files. The file
manager makes use of your MIME settings to determine what external
program is to be used.

In configuring same you may have the option to run this external
command in a window. That is an xterm or similar. This is great if
you want to see the output of the external program when it is a CLI.

So if you click on a HTML file and your MIME setting say to use
Firefox, you will get a GUI.

If you click on a RPM file and your MIME settings say to run the CLI
program 'rpm -Uvh' with the file name as a further parameter as
ellanois suggests, then UNLESS you have set things to see this is a
sub window/xterm you won't see any output.

Guess how I have my system configured?

I don't know how you have your system configured. I don't know what
version you are running ... Etc etc etc.

"Context is Everything". I know my context. Unless you tell us yours
we don't know what it is.

I don't know what you expect a file manager to run as a package
manager.


May be I'm on the right route: I have to check MIME associations and
discover how to customize it.

Tks,

--
Marco Calistri
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups