Mailinglist Archive: opensuse (1620 mails)

< Previous Next >
Re: [opensuse] Really irritated
On 11/14/2014 11:30 AM, Patrick Shanahan wrote:
* John Andersen <jsamyth@xxxxxxxxx> [11-14-14 14:16]:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 11/14/2014 10:55 AM, Carlos E. R. wrote:
On 2014-11-14 18:55, Bjarne Örn Hansen wrote:

And what's worse ... I am running KDE, what is parcellite doing and gvfs?
Why are these
gnome daemons, running on my KDE desktop?

Probably because you have started some lone gnome app which uses them.


gvfs has been with us since at least versio 11.1.
It handles MTP devices like cameras. Its pretty hard to figure out
what package draws it in when installing, or what recommends it or what
suggests it.

Yast, and zypper are pretty weak on providing tools to find out what caused
installations of packages, or what suggests packages or what recommends
packages.

#> rpm -q --whatrequires gvfs
gvfs-backends-1.22.1-1.2.x86_64
gvfs-fuse-1.22.1-1.2.x86_64
gvfs-backend-afc-1.22.1-1.2.x86_64

#> rpm -e --test gvfs
error: Failed dependencies:
gvfs = 1.22.1 is needed by (installed) gvfs-backends-1.22.1-1.2.x86_64
gvfs = 1.22.1 is needed by (installed) gvfs-fuse-1.22.1-1.2.x86_64
gvfs = 1.22.1 is needed by (installed)
gvfs-backend-afc-1.22.1-1.2.x86_64
libgvfscommon.so()(64bit) is needed by (installed)
gvfs-backends-1.22.1-1.2.x86_64
libgvfscommon.so()(64bit) is needed by (installed)
gvfs-fuse-1.22.1-1.2.x86_64
libgvfscommon.so()(64bit) is needed by (installed)
gvfs-backend-afc-1.22.1-1.2.x86_64
libgvfsdaemon.so()(64bit) is needed by (installed)
gvfs-backends-1.22.1-1.2.x86_64
libgvfsdaemon.so()(64bit) is needed by (installed)
gvfs-backend-afc-1.22.1-1.2.x86_64


Thanks for proving my point, which you quoted, but failed to understand:

Yast, and zypper are pretty weak on providing tools to find out what caused
installations of packages, or what suggests packages or what recommends
packages.

These package have a little incestuous ring of co-dependencies, but there is
nothing indication WHAT CAUSED THEM TO BE INSTALLED.

Nothing else requires them. Nothing else recommends or depends on them.

I did a clean install, and it decided to install these for some unknown
reason. I assure you I didn't select them to be installed.


--
After all is said and done, more is said than done.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >