Mailinglist Archive: opensuse (982 mails)

< Previous Next >
Re: [opensuse] Getting rid of systemd and putting sysv back
Anton Aylward wrote:
On 09/28/2014 03:20 PM, David Haller wrote:
On Sun, 28 Sep 2014, Anton Aylward wrote:
Such a fundamental gaff!
^^^^
A what?

A gaff is a hook, or a tool for pulling something in

In this context is the the root page of the articles on systemd:
http://www.freedesktop.org/wiki/Software/systemd/

Or to put it another way, such a basic URL for pulling in all the
discussion on systemd that easily refutes all that aaron-as-dirk is
saying, if he'd bothered to read it. That page has 'hooks', references.

Of course a pile more could be refuted by actually reading the code, but
that takes a modicum of understanding of C.
Gaffs-as-hooks are used at Sea as well.


Of course you could also accuse me of making a pun-as-typo: the term
'gaffe', that is a hook with a 'e' hooked on the end, means a 'blunder'.
Yes, aaron-as-dirk made a blunder by referring to "SystemD".

Well the best that can be said for aaron-as-dirk is that he takes
himself too seriously so would never appreciate such a pun.


The operation of init is self-evident. I never needed to
read hundreds upon hundreds of pages of documentation before
having a clue how it worked... all I needed to do was read
a couple paragraphs on the inittab manpage, and a couple of
paragraphs on the init manpage.

With that small bit of knowledge, I can configure any any
init-style system (SysVInit, BSD's init, etc) with a minimum
amount of fuss.

Trying to configure a systemd system to do something that
Sievert & Poeetering didn't anticipate, or worse yet, correct
something they've fucked up is, frankly, WORSE than getting
four impacted wisdom teeth removed -- and I know, because I've
experienced it.

An earlier commenter was right...

SystemD isn't just a replacement for init, but a powergrab.
If it WERE just a replacement for init, then it would continue
to just call the scripts in /etc/init.d to carry out their
various functions, instead of completely replacing their functionality.


And how is it that when I run a script in /etc/init.d, I get
some message, "redirecting to systemctl to start ... "



linux-86ja:/etc/init.d # ./cron start
redirecting to systemctl start .service
Starting CRON daemon
done
linux-86ja:/etc/init.d # grep systemctl ./cron
linux-86ja:/etc/init.d # grep system ./cron
linux-86ja:/etc/init.d #

Hmmm, the cron start/stop script contains NO references to systemctl,
not even in a comment, so I have a question --


How in the ***FUCK*** is this getting redirected to a systemctl command?

Have these assholes now hacked bash to intercept any execution of a
script in /etc/init.d


This is absolute bullshit, because now we see something else that
has been "fixed" by Poettering in the most self-serving of ways ---
rather than edit the /etc/init.d scripts to look for systemctl, and
if found, run the systemctl command, it's quite obvious that bash
has been changed to operating e a completely unexpected and undocumented manner,
all for the purpose of grabbing more power.

Fuck Sievert & Poettering, and fuck anybody who supports this fucking bullshit.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread