Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] HEADS UP! for the adventurous **NO WAY, JOSE**
On 23/03/14 15:21, David Haller wrote:
Hello,

On Sun, 23 Mar 2014, Basil Chupin wrote:
On 22/03/14 19:35, Hartmut Meyer wrote:
Am Samstag, 22. M?rz 2014, 08:44:37 schrieb jdd:
Le 22/03/2014 04:28, Basil Chupin a ?crit :
I am now working thru on how I can recover but I suspect that the only way
for me at the moment is re-install 13.1 from scratch.
is this an EFI boot? if yes look at the bios
And if that doesn't help:

Boot into rescue system, mount 13.1 and chroot into it. Reinstall bootlader.
Having never used this 'chroot' I will probably have to spend some
time experimenting on how to use it, but I will certainly try it
before re-installing 13.1 (if need be) :-) .
Basically:

# mount /dev/sdXY /mnt ### where /dev/sdXY is your /-dev for
### the "to be repaired" system, use
### lsssci/fdisk -l etc. to find the dev
# mount --bind /dev /mnt/dev
# mount --bind /proc /mnt/proc
# mount --bind /sys /mnt/sys
# cd /mnt
# chroot /mnt
[.. do stuff in the chroot like grub-install etc. ..]
[in chroot]# exit
[back in rescue]
# umount /mnt/proc /mnt/sys /mnt/dev ### could be you have to split
### that up
# sync; sync; ### just to be safe
# umount /mnt

And you should be done.

HTH,
-dnh

Well, I finally found the necessary time to try out your and Hartmut's suggestions about recovering my existing and working 13.1 after trying to install 13.2 M0 on another partition on the laptop.

All were failures - including using the Boot Rescue Disc which I found and used while playing around with Ubuntu some many months ago. I followed all the instructions given to the letter at least 3X just to make sure that I had not missed something but- alas, alack! the grub2 menu would not appear and instead I would get on the screen "Multiple active partitions", and "that's all folks".

The only problem here was that, using fdisk (and even gdisk) there were NO active partitions to be seen!

During this exercise I learnt that the HDD is formatted in GPT - the HDD originally had Windows 8 installed when I bought the laptop.

But I had no problems in installing 13.1 after I zapped W8/8.1. 13.1 went right in, "just like Flynn", and worked perfectly. I then tried to install 13.2 M0 into an empty partition (deliberately created when I installed 13.1) and which is when the wheels fell off - as you would know from earlier posts.

Following the above failures to restore the bootloader I decided that because I was getting nowhere and therefore had to re-install 13.1 what would happen if I did the following before re-installing 13.1..........

since 13.1 installed perfectly into the *FIRST* available partition[#] formatted in ext4 (ie SDA3) and attempting to install 13.2 into the *second* partition (ie SDA4) was a failure, what would happen if I now installed 13.2 M0 into the *first* partition (SDA3) and then later installed 13.1 into the second partition (SDA4)?

So this is what I did - I installed M0 into SDA3 and it all went in without a hitch. Working perfectly thank you. (But I haven't yet tried to install 13.1 - which, I suspect, might bring back the whole nightmare.)

Now, when installing 13.2 M0 I did get the message from the installer when using the Partitioner that grub2 will not work because there is no some partition which is necessary for GPT formatted HDDs - and I was asked if I still wanted to continue the installation without this special partition. I chose "Continue" and..... 13.2, as I said, was installed and working.

I don't recall getting this message when I was installing 13.1. But my memory is not perfect.

To pre-empt the person or persons who will no doubt post a reply here which will state something along the lines of, "Well you ought to know better and why didn't you create this special partition?!", I'll say this:-

"I am a brainless Windows user who just heard about this great new system called Linux and openSUSE and I wanted to try it out and I was told to download an iso of openSUSE and install it - but during the installation it came up with this stupid statement that some stupid partition did not exist and that openSUSE therefore would not boot using some silly insect called grub2."

Get the message?


[#] Sda1 btldr (to hold bootloader for multiple systems)
Sda2 Swap
Sda3 openSUSE 13.1 (ORIGINALLY - now has 13.2 M0)
Sda4 Spare for another OS
Sda5 Spare for another OS
Sda6 Data formatted in ext4
Sda7 Data1 formatted in ext4

The above is what the YaST Partitioner sees.
Gdisk sees the above as Microsoft basic, Linux swap, EFI system, EFI system, Microsoft basic, Microsoft basic, Microsoft basic, respectively.

BC

--
A civilisation is judged by how it treats the most vulnerable.

Lauren Smith - 30 January 2014

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >