Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] Moving / and /boot partitions
Felix Miata wrote:
On 2014-03-23 08:19 (GMT-0400) James Knott composed:

In preperation for a new motherboard, I'm moving my system from a pair
of IDE drives to a SATA drive. I have copied all the partitions by
using cp -a to the new drive. However I cannot get the system to boot
with / and /boot on the new system. I have tried various things
including the Yast Boot Loader and grub2-mkconfig, but can't seem to get
the new partitions to work. While I realize I could just reinstall to
the new drive, I'd prefer to move the existing system over.

I do what you're trying to do often, and successfully, but I use rsync
-av instead of cp, or literally clone followed by changing volume
labels and UUIDs on the cloned filesystems. Ultimately Grub needs to
be installed/configured correctly on the appropriate new location(s)
as well. All my Grub cmdlines and fstab entries for Linux native
partitions use volume labels rather than UUIDs, device names or device
IDs. I have too many installations successfully created this way to
keep track of, though none of my openSUSE installations have Grub2 or
os-prober installed, including my 12 13.2m0 and 17 13.1 installations,
besides older and other distros.

Maybe you should tell us exactly what steps you took rather than
summarizing. You might be on the edge of success, missing just one
little thing.

I also use volume labels, rather than device ID.

The first thing I did was create mount points for the new partitions,
with the usual names, but with x appended. For example, I created
/homex, /tmpx etc. and then mounted the new partitions on those mount
points. I then copied the contents from the old to new partitions,
using cp -a. As I understand it, rsync doesn't make any difference in
the end result, when copying to an empty partition. I then went through
fstab, removing the trailing x from the new partitions and added it to
the old ones. I later disabled mounting the old partitions by inserting
a # at the beginning of the lines for the old partitions. I have tried
running the Boot Loader in Yast,, grub2-mkconfig and even tried running
an update from the install DVD, but that also failed. I also used fdisk
to verify the new drive is bootable.
BTW, with the original Grub, it was possible to have descriptive titles
in the boot menu, so that you knew what you were booting. Why isn't
this possible with Grub2. Even in the advanced menu, I only see 4
entries with identical titles.

How about showing us the relevant portions of the file containing
those stanzas? Did you do any manual editing of grub.cfg? What if
anything have you done with /etc/default/grub on the SATA? Have you
done anything in the BIOS to make sure the SATA is HD0, or tried
booting the SATA with both PATA removed (power and/or control cables
disconnected)? Exactly what is the BIOS setting for HD controller(s)
when failure is occurring? Are you already trying to use the new

I have no idea what file contains those. It's whatever appears after
selecting Advanced from the initial boot menu. I have the BIOS
configured to give the new drive priority for booting. When I
disconnect the PATA drives, I cannot even boot through the DVD.

Why is something that used to be so simple now so difficult? Back in
the DOS/Windows & OS/2 days, it was simply a matter of copying the
partition and setting the boot flag.

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups