Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] Grub2 corrupted after Yast or Zypper updates
  • From: Tony <tonys@xxxxxxxxxxxxxxxx>
  • Date: Wed, 19 Mar 2014 13:08:51 -0500
  • Message-id: <CAENB-MT1Shp9_PF9-v3pvjaVPZEVUfnE=wP466Q0NB8M01X49A@mail.gmail.com>
bootinfoscript is run inside VM, before I fix grub by booting via
super grub2 or after fix ?

On Wed, Mar 19, 2014 at 12:16 PM, Andrey Borzenkov <arvidjaar@xxxxxxxxx> wrote:
В Wed, 19 Mar 2014 12:06:34 -0500
Tony <tonys@xxxxxxxxxxxxxxxx> пишет:

When using VirtualBox 4.3.x and running opensuse 12.3 or 13.1 guest,At
random after updates are applied via yast or zypper, somehow the grub
boot loader, get's corrupted.

At this point the vbox guest opensuse vm will not boot, instead all
one see's is a black screen, with the words grub in approximately the
upper left part of screen and nothing else displays.


This usually means that grub first stage (bootsector) tried to load and
execute garbage.

The vm is recoverable, I just boot the vm using super grub2, then
grub2-mkconfig -o /boot/grub2/grub.cfg then grub2-install /dev/sda,
reboot all is good.

Any ideas as to what would be causing this and/or prevent it from happening.


Could you run
https://github.com/arvidjaar/bootinfoscript/raw/master/bootinfoscript
inside of VM and upload result to susepaste.org? Also show
your /etc/default/grub_installdevice.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
References