Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] uefi boot on asus 1225B with only openSUSE
On 09/03/14 06:54, oszko@xxxxxxxxxxxxxxxx wrote:
Id├ęzet (Ken Schneider - openSUSE <suse-list3@xxxxxxxxxxxxx>):

On 03/08/2014 01:37 PM, jdd pecked at the keyboard and wrote:
Hello,

some friend of me asked me to install ubuntu on his asus 1225b computer,
wipping all trace of windows.

So I inserted the unbuntu 13.04 disk, installed without problem... and
couldn't boot it, error "no system found".

This is uefi bios, gpt disk.

So I inserted the openSUSE 13.1 dvd... and... same punishment!!

I tried all what passed in my mind: verifying /boot/EFI partition was
mounted (it was), trying to set a boot flag (not available in efi/gpt
system), even trying to add manually efi system files ("Windows Boot
Manager.efi" or "Shellx64.efi" as the bios seemed to ask for.. nope.
Even tried ELILO without more success.

I now try to install with standard MBR and grub2 (non efi), and hope to
succeed.

but I would really like to install with efi/gpt system, let only for the
record :-))

any idea?

thanks
jdd
(I wonder if an double boot system would have worked, any people testing
thies on this pretty common computer?)

I turned off EFI as I only had one OS to install (openSUSE). If you don't intend to ever use MS again That may be the way to go.

--
Ken Schneider
SuSe since Version 5.2, June 1998
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx



Hi all,

I have/had somewhat similar and also different experience on a Lenovo G505 (in a previous thread). I can install with both UEFI and Secure Boot set in BIOS only 64 bit openSUSE. No other 64 bit systems (tried Debian and descendants, Ubuntu, Mint) could be installed with UEFI. I disabled secure boot and chose Legacy first instead UEFI and then all 32 bit systems could be installed. Now I am on oS 64 bit, but there are problems, boot runs only when Advanced settings/recovery mode is chosen on the boot screeen. Probably there are no drivers yet for the machine:

I have oS 13.1 64 bit(UEFI and secure boot on) with KDE 12.2 and XFCE, AMD A4 CPU, ATI 8670M video and also AMD sound. Kernel 3.11.10-7. Win 7 in virtualbox works perfectly, but could not install it nicely when I wanted a dualboot, because I had no drivers for Win7. They are available on the vendors site.
Yesterday I tried to upgrade to kernel 3.13 but I only got "grub>" prompt. Was terrifying.

Now this is EXACTLY what happened to me a couple of weeks ago on my Lenovo (which came with W8 pre-installed.)

Some updates were done to 13.1 and on boot I just got 'grub>' and that's it! There was no way I found to recover - even though all partitions and files were on the HDD - so I wiped the whole disc and just re-installed 13.1 .

(But now, the darn wi-fi doesn't work whereas before it was working perfectly after the first installation of 13.1.)

BC

--
A civilisation is judged by how it treats the most vulnerable.

Lauren Smith - 30 January 2014


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >