Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
[opensuse] [long story] HP server/NIC/router/gateway frustration
Internet friend Georg from 4,000 miles away bought a house near me. He subscribed to cable, installed an internet router, and installed a Logitech camera system so that he could monitor his house here from his distant home. That system continues to work via the Logitech module plugged into a router LAN port.

Later he bought a HP Windows 2011 server puter with no OM drive to use for remote desktop so that he could pay bills from local utility systems whose archaic billing systems do not accept international payments in sensible fashion electronically. Remote desktop was supposed to solve the problem by making the transactions look local, created via online banking with a bank located across the street from the utility. RDP worked for a time, but stopped when the HP became unable to access the internet.

I brought his HP here to troubleshoot. The problem appeared on the basis of its lights not lighting up when a cable is plugged into it to be the onboard NIC died, probably as a result of our area's infamous power outages hitting his unprotected-by-UPS HP. I had no NIC to test with because his HP has no PCI slots and I had only PCI NIC spares to test with. Hoping for a minimal likelihood of compatibility issues I ordered and installed http://www.newegg.com/Product/Product.aspx?Item=N82E16833106033 . With it installed and the HP plugged into my LAN everything appeared to be copasetic with regard to the HP, though leaving it on long enough for Windows to do updates left my Samba dysfunctional for more than 24 hours while I tried to figure out what went wrong and how to fix it[1].

When I took the HP back to its home, it still refused to see the internet. Blinking router lights on unconnected ports made me think the router had been damaged at the same time as the NIC. Not wanting to disturb continued function of the camera system, I quit trying and brought the HP back here, then ordered Georg's choice of new router, D-Link DIR-655.

The new router like most consumer products nowadays comes with no paper manual, just a short quick start sheet. A PDF manual comes on a CD with a Windows driver and Windows installation Wizard utility that in big black letters on an big orange sticker on the router says must do first. Of course this is not possible because I have no OM USB device to read the CD, and his HP has no OM drive to read it either. I called D-Link support to report the media type problem, and complain about the upside down ethernet ports and port labels underneath the ports instead of above where they would be visible. I was told by machine the wait queue was 11+ minutes. 64 minutes later after no further response I hung up. I've never bought D-Link before. I'll never buy D-Link again.

I tried testing it all here sans manual by plugging the new router into my router via the same cable normally used for my test puters, with the brand new router's new ethernet cable connecting new NIC to router port 4. On first try, no luck, no NIC lights. I removed the new cable from the NIC, and plugged one of my cables into the NIC and router port 2. Wired thus, router chained to router, it enabled Firefox to reach the internet, and the new router's setup utility page. I proceeded through the router's initial setup "wizard", setting a name and password for wireless. At the end of that process the router purposefully rebooted itself. Since that reboot, nothing I do makes the exclamation mark leave the Windows network function icon, or the new router's light for that port stop blinking. FF cannot reach the internet.

I shut the HP down, then plugged one of my (multiboot) openSUSE systems into the new router using my own same cable. I first tried 12.1. It too could not reach internet (no response to ping www.google.com). This made me think my first try at chaining the two routers succeeding was either a fluke, or something via running the new router's wizard was blocked/canceled/destroyed.

So my plan is now to figure out how to get openSUSE to see the internet through both routers. Once that's done, I'll need to make a live Linux USB stick (that's been waiting for an available round tuit for many moons), and ensure that whatever I got to work on my own system will work reliably on the HP, possibly with its old NIC. As another option alternative to USB, I could temporarily remove the HP HD (a quick and easy process) and put in one of my own with openSUSE already configured for Intel CPU and HD controller. Once I know I have the HP working reliably with live Linux or my own HD, I can then see about getting Windows to do as well. Then once that's done I can try taking the HP and new router to Georg's house.

So, step next: get any openSUSE from 11.4 up through 13.2 to reach the internet through both routers. Is there something special that needs to be done WRT routing or DNS setup for such a router configuration to succeed? Anything else I'm missing?

[1] http://lists.opensuse.org/opensuse/2014-01/msg00943.html
Additionally, every time the HP connects to``````` my LAN, my own router changes the HTTP port assignment from where it belongs for running Apache to the IP assigned via DHCP address to the HP.
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >