Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Toshiba laptop with 12.3 - automatic suspend/resume stopped working after latest updates
On 07/01/14 01:43, Marco Calistri wrote:
Il 06/01/2014 05:30, Basil Chupin ha scritto:
On 06/01/14 03:06, Per Jessen wrote:
Jan Ritzerfeld wrote:

Am Samstag, 4. Januar 2014, 19:21:22 schrieb Per Jessen:
Jan Ritzerfeld wrote:
Am Samstag, 4. Januar 2014, 17:22:11 schrieb Per Jessen:
Jan Ritzerfeld wrote:
Jan 04 15:16:43 toshiba1 systemd-logind[669]: Lid closed.
Jan 04 15:16:46 toshiba1 systemd-logind[669]: Suspending...
Jan 04 15:30:17 toshiba1 systemd-logind[669]: Lid opened.

What is missing is my closing the lid again ... (and the machine
wasn't suspended either).
But the lid close is detected and logind tries to suspend. That is
Except it only happens once.
So, do I understand correctly that the suspend does never work when
closing the lid? Even the very first time when the lid close is
That is certainly how it looked yesterday. Now however, it it doesn't
seem to work at all.

So: 1. Is the suspend attempt above recorded in
/var/log/pm-suspend.log? Date and time of the attempt are printed
in the second line. Are there any errors in this log?
Yes, that attempt is recorded, and I don't see any errors.

2. Does "systemctl suspend" work?
Yes, works fine.
Are there any differences in /var/log/pm-suspend.log between the
working suspends and the failing one?
There isn't really a failing suspend, the suspend simply doesn't happen.
The automatic resume doesn't happen either.
I am coming in in the middle of this thread and do not know what has
been said earlier, but the words "laptop" and "closing lid" and "won't
suspend" got my attention.

I have a ThinkPad and I had installed 13.1 several days ago (after
getting rid of Windows and reformatting the HDD).

The laptop will NOT *shut* down: the screen goes black but the cursor is
still on the screen and the only way to switch off the laptop is to
press/hold the on/off switch.

The interesting part is that when I bought the laptop it had Windows 8
installed and I installed 13.1 - and 13.1 behaved perfectly. But then I
wiped W8 and did a clean install of 13.1 and now the laptop will not

If it is of any help, I do have the latest stable kernel installed on
the laptop (kernel whereas previously I had the standard
kernel (3.11.x which comes with 13.1) installed.


I have a Lenovo Z470 laptop wherein I installed 13.1 64bits (I believe
it is similar to ThinkPad line) and with this hardware the suspend on
RAM/hibernate never worked automatically when battery reaches critical
threshold since openSUSE-12.3.
Simply the laptop shut-down in the middle of my works whenever battery
goes below the minimal level and this is a very annoying behaviour.

Manual suspend/hibernate works but I would like the automatic feature!


I run my ThinkPad on AC power 99.9% of the time so the state of the battery doesn't come into it.


Using openSUSE 13.1, KDE 4.12.0 & kernel 3.12.7-1 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel Corsair "Vengeance" RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX660 OC 2GB DDR5 GPU

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >