Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Video Regression from 11.1 to 12.3 with Radeon 7000
Larry Stotler wrote:
I've done a great deal of searching & I can't seem to find a useful solution.

I finally got around to getting my old 11.1 install running on my
Thinkpad A30p with Radeon Mobility 7000. With 12.3, The video
performance is slow, and I can't get MPlayer to play a video at all.
With 11.1, I can play an x264 480p video with no problem. The laptop
has a Tualatin P3/1.2Ghz & 1GB RAM.

I've found all kinds of suggestions, like turning off KMS or creating
an xorg.conf file and changing accelmethod from EXA to XXA. Turning
off DRI made no differnce.

Nothing works. There seems to be a similar regression with uBuntu
from 8.10 to 9.04 as well.

I tried to copy the xorg.conf from 11.1 to 12.3 but it fails to load.

Has anyone managed to get this video chip working properly with newer
versions of oS?

<and then>

Well, it seems that my 11.1 install is using the radeon driver. It
has KDE 3.5.9 installed. The 12.3 install has TDE 3.5.12 installed.
The only difference between the 2 installs is that on the 12.3 install
the /home directory is encrypted. The 11.1 install won't decrypt the
12.3's /home directory so I can't check to see if that is part of the
problem. After playing with the 11.1 install I can tell that it is
somewhat faster, and scrolling in Firefox is smoother but still not
fluid.

I've tried disabling kms but that didn't help either. Oh well. Other
than installing XP to see if its any better I guess I'm stuck with it.

Thanx

Maybe not quite the same as your problem, but a lot of what you originally wrote sounds all too familiar to me and there might be a connection given the timeframe...

I had a Mobility Radeon 9700 card on my old laptop, which is based off the desktop 9600 card that I also had installed on another machine. I installed every version of SUSE / openSUSE on these machines from the 9.x series onwards. In both cases, I could never get the ATI FGLRX driver to install (or even if apparently installed, to work), and then support was dropped for this generation of card anyway. In the old days, it wasn't important because the system functioned fine in 2D with whatever driver was default (software rendering? I've no idea now), with videos playing no problem and resource demands not high. Just no good for gaming or any rare 3D-centric apps Linux users of the time might have used (e.g. Google Earth).

It was only around the start of the 11.x series that the free radeon driver started to become a bit capable, but there were a few glitches and strange things going on, and 3D wasn't really ready or working.

At the point where KMS was introduced in the 11.x series, it all went tits up on both machines, I suffered constant freezes and other graphical issues using the radeon drivers and over the course of about 3 or 4 YEARS I tried everything I and others could think of, including what you list above. I sought help on forums, mailing lists, and contributed to existing bug reports as well as filing new ones, but got nowhere. On openSUSE Bugzilla, some reports still remain unanswered years on. If I didn't supply a bucket load of info or logs, the only responses would be 'can't help if you don't provide this or that', and if I did provide these things there would simply be silence. I knew this wasn't a faulty card since I could reproduce the same issues on an otherwise unrelated desktop and laptop, and I'd read occasional similar reports from others which never ultimately threw up any solutions.

The AGP Radeon card I'd paid good money for and installed in the desktop was never really put to good use since it was effectively reduced to 2D only, but I was at least able to replace it years later, whereas on a laptop you're screwed. The only thing that kept the laptop usable over several years was putting a line in the 50-device.conf file as follows:

Option "NoAccel" "true"

...which forces the card to avoid exploring the 3rd dimension, and made my laptop pretty hopeless for watching video or doing anything more than basic tasks. With each openSUSE release becoming more and more demanding resource-wise, by 12.3 it had become unusable without full radeon functionality and I had to finally abandon it.

So depending what you need this machine for, if you can put up with an old 11.1 installation and run the security risks (especially if it's offline) I'd just stick with that. If you were hoping to install new versions of software on it I reckon your luck's out.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >