Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Intermittent sound dropouts with Pulseaudio
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 12/31/2013 06:17 AM, Bob Williams wrote:
Last night I upgraded to 13.1 (zypper dup), and I regret to say, I'm
still getting the same problem.

The worst offender is Google maps (and any page that uses Google
maps), especially when zooming in/out, but also sometimes when
scrolling. It was worse using the 'old' Google maps, but it also
happens with the new version.

It also happened when running a perl script that made frequent calls
to perlMagick to resize about 2,000 jpg images, amongst other jobs.
This script uses all 4 cores in my CPU at between 50 and 75% according
to gkrellm. Pulseaudio is supposed to run with a niceness of -11, so
how does a program (perl) run from the command line push it out of the
way? Or is the conflict happening somewhere else? Alsa? Gstreamer? Or
is nice not respected?

Bob

Sigh....

The frustrating thing is sound would just "work" in the past. I probably spent
a week on this issue a year or so ago. If I recall, it was skype that prompted
my dive into the issue, ver. 3 worked, ver 4 didn't. I dorked with with
pulseaudio-alsa, messed with kcmartsrc, messed with pulse/system.pa and
default.pa, played with autospawn in pulse/client.conf, etc.. -- and through it
all I found I could make my problem worse, kill my sound all together, but not
find a fix that made sound work consistently through all applications (i.e.
kde/gtk/browser web plugins/etc..) Skype was a pain, it would work with a very
narrow config that broke sound for everything else, and not work when sound for
everything else worked. No, I never looked at cannibalizing and rebuilding
pieces of the sound puzzle, I just never had the time to dork with it.

Another thing, as you have found with your sound card switch, is that sound
will work fine on some hardware, but be miserable with other hardware. My
laptops work fine, the dell boxes I have are hit and miss - same with the custom
boxes I have (using onboard audio - no high-end sound cards) I have seen no
consistency in motherboard manufacturers/sound chipsets either. I have MSI,
Tyan, Gigabyte, VIA, etc.. and it is really hit or miss.

In the end, it was like the pieces of the sound puzzle didn't all match the
slots linux has for them. I suspect it is just a hard for the guys packaging the
sound drivers/packages in the various desktops and apps to keep up with kernel
and hardware changes as it is for anyone else, but the frustrating part is (1)
the old stuff should just work, and (2) if it doesn't, there should be a good
sound wiki somewhere that could walk you though a decision tree to find out why
it doesn't and help you fix it. So far, I haven't found either....

I'm interested in whatever else you find as well.

- --
David C. Rankin, J.D.,P.E.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlLEf5gACgkQZMpuZ8CyrciaKgCffrZby6yJiTYDs6tfp4e/50x+
wrcAmwXBq8Ecz5qO7j5QA2j6CRpC22jy
=isqL
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages