Mailinglist Archive: opensuse (878 mails)

< Previous Next >
Re: [opensuse] ssh login to openSUSE 12.2: Connection refused



2013. szeptember 4. 21:21 napon John Andersen <jsamyth@xxxxxxxxx> írta:

On 9/4/2013 11:56 AM, Istvan Gabor wrote:



2013. szeptember 4. 20:07 napon John Andersen <jsamyth@xxxxxxxxx> írta:

On 9/4/2013 10:40 AM, Istvan Gabor wrote:
Hello:

I have a problem with ssh login to openSUSE 12.2 system.

sshd is running and listening on port 4321

port 4321 is open in the firewall:

In /etc/sysconfig/SuSEfirewall2 file there is a line

FW_SERVICES_EXT_TCP="146"

When I try to login to the system I get an error message:

ssh -l user -p 4321 <my-opensuse-host>
ssh: connect to host <my-opensuse-host> port 4321: Connection refused

In /etc/ssh/sshd_conf file I have this line:

AllowUsers user


The same configuration worked in previous openSUSE systems (12.1, 11.2).

How could I check what the problem is and fix it?

Thanks,

Istvan





Sorry, last replay went direct, meant it to go to the list.
But since it did, this one is coming direct as well.

In none of my SSHD configs do I have the settins
AllowUsers user

You might try to comment that out at least temporarily.

user is the login name of one of the users.
That causes that only the specified user, in this case 'user' can login
by ssh. Because other users do not have strong passwords I can't
let them login by ssh.

Cheers,

Istvan


Ah, I see.

I've turned off password authentication on all my machines and only use
public key now.
In any event I did have the issue with AddressFamily inet only after
updating to 12.3, but then I skipped 12.everything-else.


Hello:

This one has been solved.
I thought that sshd service was enabled but it was not.

After enabling sshd by

systemctl enable sshd.service

ssh login works.

Sorry for the confusion.

Thanks,

Istvan

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread