Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] Problem with USB headset microphone volume
On 26/08/13 02:48, Jim Sabatke wrote:
On 08/23/2013 10:15 PM, Basil Chupin wrote:
On 24/08/13 07:30, Jim Sabatke wrote:
On 08/23/2013 05:42 AM, Basil Chupin wrote:
On 23/08/13 20:11, Jim Sabatke wrote:
SUSE 12.2
Plantronics Audio 478 USB Headset
KDE
Volume Control Programs
- pavucontrol
- kmix
HP G72 Laptop

I can't seem to get any volume out of my headset microphone. If I max the volume on either control program, I can hear if I scratch my fingernail on the mic, or if I stick the microphone in my mouth and yell, I get a very low volume, highly distorted sound through the headset. The sound level bars pavucontrol show high responsiveness to sound, but it doesn't come through the headset.

<snip>

Jim

Pulse/pavucontrol are sitting on top of alsa. Have you configured alsa? If no then-

on a comman line run

alsamixer

<snip>

Once you have this right then pavucontrol will work.

BC

Configuring alsamixer was the most common fix I found on the internet and it was the first thing I tried. I've been trying to find a configuration that works, but no luck. I can get it configured so that the sound level bars show appropriate levels, but only very faint sound through the headphones. BTW, mm on my system turns off the input / output and 00 turns them on. Alsamixer v1.0.25, if that makes a difference.

Jim

The version I have is 1.0.26 but that is neither here not there.

Re the "oo" and the "mm": yep, I was working from memory and what you state is correct- "oo" ON and "mm" is OFF.

Puzzling problem. Did you have some sound being generated when you were fiddling with the channels? While I don't use a headset with a mic I found that I couldn't get sound out of the speakers because of a certain combination of channels being active at the same time; I happened to turn off some channels and suddenly had sound from the speakers.

The other thing is with pavucontrol.

I have a 5-1 sound system and have all 5 of the speakers operating OK. However, when I watch a DVD I use headphones and when I do I lose most of the sound in the movie. Reason? The headphones are stereo of course and therefore lose sound from anything except the left and right channels. To get full sound I have to go into pavucontrol and select the stereo output which combines all sound and I can then hear the movie perfectly.

I wonder if this is what may be causing your problem (the headset is 'stereo' afterall)?

BC


Actually, I have no problem hearing DVDs or any other media at all. I've been seeing some reports online that there are problems getting the machine to use input and output at the same time. I need to look into it further as it is getting beyond my expertise. I may have to compile a kernel module.

The point of my message was to prompt you to look at the whether these may eliminate your problem. Telling me that you have no trouble playing DVDs or any other media is immaterial. If you have tried out what I raised and found that it made no difference then I will accept that and until you do this leaves questions about whether these are causing your problem. You see, from what I have been led to understand pulse/pavucontrol has been 'created' to be able to do just what you want done; pulse/pavucontrol is supposed to handle input from a variety of sources simultaneously and output them - something which is something that alsa cannot do.

BC

--
Using openSUSE 12.3, KDE 4.11.0 & kernel 3.10.9-1 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel Corsair "Vengeance" RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX550Ti 1GB DDR5 GPU


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >