Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] DHCP server, VLAN and subnets
Andrey Borzenkov wrote:
So far it simply sounds like DHCP requests are coming to your server
via the wrong interface.
Here's what I posted in an earlier message:

Here's an example. This arp cache shows the connections before I put
the computer E520 on the VLAN.

nexus7.xyz.net (172.16.1.95) at 08:60:6e:a8:96:0d [ether] on eth2
default (99.230.168.1) at 00:1f:ca:20:46:da [ether] on eth0
linux.xyz.net (172.16.1.10) at 00:15:f2:9c:a7:ac [ether] on eth2
E520.xyz.net (172.16.1.40) at 38:59:f9:e0:7d:5d [ether] on eth2


And after I put it on the VLAN and manually assign the IP address.

nexus7.xyz.net (172.16.1.95) at 08:60:6e:a8:96:0d [ether] on eth2
default (99.230.168.1) at 00:1f:ca:20:46:da [ether] on eth0
? (192.168.5.50) at 38:59:f9:e0:7d:5d [ether] on eth2.5
linux.xyz.net (172.16.1.10) at 00:15:f2:9c:a7:ac [ether] on eth2
E520.xyz.net (172.16.1.40) at <incomplete> on eth2

As you can see, the arp cache shows the computer as now on the VLAN
eth2.5 with address 192.168.5.50. Since this is the router computer,
that info is available to the DHCP server. The question mark in the
host name is due to there not being any DNS entry for that IP address.



Please note the MAC address 38:59:f9:e0:7d:5d. When it's connected to
the main WiFi SSID, it shows up on eth2, with the IP address
172.16.1.40, as expected. When I connect to the VLAN SSID and manually
assign the address 192.168.5.50, it's on eth2.5. Prior to changing the
address, it still had the 172.16.1.40 address, but pinging anything
returned unreachable.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >