Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] video problem with an ancient laptop
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Tue, 13 Aug 2013 14:09:53 +0200 (CEST)
  • Message-id: <alpine.LNX.2.00.1308131359330.305@minas-tirith.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Content-ID: <alpine.LNX.2.00.1308131404390.305@minas-tirith.valinor>


El 2013-08-13 a las 00:19 -0400, Felix Miata escribió:
On 2013-08-13 02:17 (GMT+0200) Carlos E. R. composed:

IIRC, 5.2's 2.6.33 was the last kernel version without having KMS built in by
default. Given why that distro exists, it's pretty safe to assume it had no
KMS.

I suppose so.

Response to vga= and absence of response to video= makes it clear.

In openSUSE? I'm using those parameters in openSUSE 12.3, not puppy.


It shows that the hardware is capable :-)
If it worked with older linux software, it should also work with recent
software.

That's the theory. Tell it to people who bought hardware last century.

Yes, but the theory also says that only prprietary hardware suffers that malady often. Certain ATI cards, specially.

As I said upthread, the 845G has been, and remains, particularly problematic:
https://bugs.freedesktop.org/buglist.cgi?short_desc=845g&query_format=advanced&short_desc_type=allwordssubstr

Just my luck. But could be worse: could have been an ATI. >:-)


But "video" does not work,

Can't without KMS.

and "vga" does. And lsmod shows that drm, i915,
drm_kms_helper, are loaded.

Still running Wary 5.2's 2.6.33? In 12.3, of course it would, absent nomodeset or i915.modeset=0 on cmdline.

No, openSUSE. Puppy was installed first for testing and for creation of a swap partition in advance, while the i586 DVD downloaded: two days on my ADSL.

I'm using openSUSE since then, and it uses KMS. All this thread is about openSUSE, save a paragraph or two for puppy.


Xorg log says kms is in use.

Xorg.0.log running 2.6.33 kernel? That doesn't sound right for a distro intended for old hardware. KMS was in testing in the 2.6.33 period, so might have been reported to apply by mistake via Xorg or driver bug.

Again, openSUSE, kernel 3.7.10. I'm using openSUSE 12.3 all the time, my problem (solved) is with it.


The display runs at 1024x768x60, I think.

That's XGA.

yes.

- -- Cheers

Carlos E. R.
(from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)

iF4EAREIAAYFAlIKIhsACgkQja8UbcUWM1ztVwD/ZgKBdmdnTBz3rc1rwI+p39vQ
bREoSvy/+O/aEhZ/8isA/3obVjY+bKYsJ+ULKAHLiTyZOMSqT6why3GR1UyiXn/b
=y3WB
-----END PGP SIGNATURE-----
< Previous Next >