Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] Troubles with Nvidia
[08.08.2013 13:50] [Vojtěch Zeisek]:
Hello again ;-)

Dne Čt 8. srpna 2013 12:02:05, Werner Flamme napsal(a):
[08.08.2013 11:35] [Vojtěch Zeisek]:
Hello

Dne Čt 8. srpna 2013 05:52:09, David Haller napsal(a):
Hello,

On Wed, 07 Aug 2013, Vojtech Zeisek wrote:
Dne St 7. srpna 2013 20:15:06, Werner Flamme napsal(a):
[07.08.2013 19:03] [Vojtech Zeisek]:
[..]

# nvidia-modprobe
FATAL: Error inserting nvidia (/lib/modules/3.7.10-1.16-desktop/weak-
updates/updates/nvidia.ko): No such device
# find /lib -name nvidia.ko -print
/lib/modules/3.7.10-1.16-desktop/weak-updates/updates/nvidia.ko
/lib/modules/3.7.10-1.1-desktop/updates/nvidia.ko
WTF? Should I blacklist the nouveau driver to force loading of nvidia?

Yes. And you may also have to adjust the INITRD_MODULES="..." variable
in /etc/sysconfig/kernel (remove nouvau if it's in there, add nvidia).
Then run mkinitrd.

Done, no change, still using nouveau.

After changing this, you have to re-create the initrd. Did you use the
mkinitrd command?

Of course. :-)

BTW:

a) there's sax3 in the repos, no idea how that works though (see

before sig)

I tried. It doesn't seem to be very useful right now. It created 99-
saxdevice.conf, 99-saxmonitors.conf and 99-saxscreen.conf in
/etc/X11/xorg.conf.d/ and the device section knew just Intel driver. After
changing to nvidia, X didn't start. I deleted those configuration files.

It might have caused the intel graphics controller to work, after you
created a new initrd (and maybe rebooted from it).

# nvidia-modprobe
FATAL: Error inserting nvidia (/lib/modules/3.7.10-1.16-desktop/weak-
updates/updates/nvidia.ko): No such device

For me, a simple "modprobe nvidia" works.

# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/3.7.10-1.16-desktop/weak-
updates/updates/nvidia.ko): No such device

[ 179.017] (II) NVIDIA GLX Module 319.32 Wed Jun 19 14:55:38 PDT 2013
[ 179.017] Loading extension GLX
[ 179.017] (II) LoadModule: "nouveau"
[ 179.018] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so

This should not happen, since the module should be blacklisted (see
Andrey's post).

I added nouveau to blacklist in /etc/modprobe.d/50-blacklist.conf:
# lspci -nnk | grep VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core
processor Graphics Controller [8086:0166] (rev 09)
Subsystem: Hewlett-Packard Company Device [103c:181b]
Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce
GT
630M] [10de:0de9] (rev a1)
Subsystem: Hewlett-Packard Company Device [103c:181b]
Kernel driver in use: nvidia

So? It looks better. Although bumblebee doesn't run:
# optirun glxgears
The Bumblebee X server was not available, please check the
Bumblebee logfile at /var/log/bumblebee.log



==================================================

Now, I'm unsure about logs, because they don't show real time and don't make
sens. :-)

Quite right. I love systemds logs :-\

Obviously, bumblebee always uses tne nouveau module. Can you configure
bumblebee somehow in that respect? Or is it all magic?


On <http://en.opensuse.org/SDB:Configuring_graphics_cards> under "5th
thing" it is written that 'Xorg -configure' will create the file
/root/xorg.conf.new.

Yes, I saw, but anyway, it is not usable without long tweaking... But it
seems
to be the only way as far as I see...

Sigh. Once more I am conviced to never buy a notebook with anything else
than intel graphics...

Regards,
Werner
--

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups