Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] Creating the distro USB stick with a simple 'cp'
  • From: "Carlos E. R." <carlos.e.r@xxxxxxxxxxxx>
  • Date: Tue, 6 Aug 2013 22:46:07 +0200 (CEST)
  • Message-id: <alpine.LNX.2.00.1308062222340.305@minas-tirith.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256



El 2013-08-06 a las 13:19 -0700, John Andersen escribió:
On 8/6/2013 1:13 PM, Carlos E. R. wrote:

Someone can explain why it works? Or why it should not work?

It worked because what ever Operating System he plugged it into knew how to
mount
an ISO as a loop-back device.

In other words, it shouldn't have worked, but it did on his machine and may on
yours, but probably won't on many others.

In a perfect world he would not get to write onto a device mounted via loop,
but who knows.

The ISO was not mounted at all, loop or otherwise. Loop is not involved in this. The stick was not mounted at all, either.

It is a raw copy, despite the appeareances, not a file copy.

At least, it works on Debian, Ubuntu, and openSUSE.


I just did the reverse operation:

# umount /media/openSUSE\ 12.3\ Live/
# time cp /dev/sdd image_cp

real 1m46.887s
user 0m0.069s
sys 0m11.177s
# # time dd if=/dev/sdd of=image_dd
3919872+0 records in
3919872+0 records out
2006974464 bytes (2.0 GB) copied, 103.094 s, 19.5 MB/s

real 1m43.488s
user 0m1.127s
sys 0m24.280s
#

# cmp image_cp image_dd
#

Same image, success.


interestingly, cp uses less CPU time.


- -- Cheers

Carlos E. R.
(from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)

iF4EAREIAAYFAlIBYI8ACgkQja8UbcUWM1zBVwD/dgF2MewDr75c+/s4lqcZIvNn
k+x1K2MmbcowxnsyyRcA/i8X1GdfxHbVkGahzPWgpJt0Vq7lnLpufgqgt+qJW+9O
=qcvc
-----END PGP SIGNATURE-----
< Previous Next >