Mailinglist Archive: opensuse (880 mails)

< Previous Next >
[opensuse] 64-bit GLX config problem
I'm trying to run GLX over X, but when I run glxinfo -b for the "best visual"
I get:
libGL: OpenDriver: trying /usr/lib64/dri/updates/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/updates/swrast_dri.so
libGL error: dlopen /usr/lib64/dri/updates/swrast_dri.so failed (/usr/lib64/dri/updates/swrast_dri.so: cannot open shared object file: No such file or directory)
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL error: failed to load driver: swrast
33

Are these files located anywhere?

I have both the 64 & 32 bit Mesa and supporting packages installed...

I see ".so" files in /usr/lib64/dri/, but see nothing in
updates other than a README:
-------------
DRI Driver update mechanism
---------------------------

If any corresponding DRI driver is found in "/usr/lib/dri/updates/"
it will be favored over the one in "/usr/lib/dri/" and will be used
for 32/64 bit applications.

On 32/64 bit biarch platforms additionally a corresponding DRI driver
in "/usr/lib64/dri/updates/" will be favored over the one in
"/usr/lib64/dri/" and will be used for 64bit applications.

----
Any reason why it doesn't use the ".so" in
/usr/lib/dri/ ? From the above, it doesn't appear to even
try to load the driver from there.

Perplexed..
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages