Mailinglist Archive: opensuse (686 mails)

< Previous Next >
[opensuse] md stealing disks!
Hi Folks,

Here's an odd one. I pulled a "zypper dup" yesterday on
a 12.3 x86-64 without any obvious issues.

But today, I connected a brand new 3.5-in SATA disk to the
system with one of those SATA/USB converters. I do this
all the time and have never had any issues.

So, I "tail -f /var/log/messages" to get the /dev/sdx id
and then run fdisk /dev/sdf, in this case. I create one
Linux partition using the whole disk. No problems noted.

But now, when I run "mkfs.xfs /dev/sdf1" I get this error:

"mkfs.xfs: cannot open /dev/sdf1: Device or resource busy"

df doesn't show anything, and the Device Notifier is quiet.

I then notice this in /var/log/messages:

"[ 1122.179127] md: bind<sdf>"

It looks like md is snatching the disk! But I'm not running md,
to the best of my knowledge. A "ps ax |grep -i md" shows:

90 ? S< 0:00 [md]
95 ? SN 0:00 [ksmd]

Is systemd quietly starting md which is then trying to be helpful?
"kill -9 90" doesn't touch the process.

"cat /proc/mdstat" shows:

Personalities :
md126 : inactive sdf[0]
976224256 blocks super external:/md127/0

md127 : inactive sdf[0](S)
538328 blocks super external:ddf

unused devices: <none>

This process of adding/formatting disks has worked for decades before
yesterday's zypper dup. Are other folks seeing this?


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >