Mailinglist Archive: opensuse (686 mails)

< Previous Next >
Re: [opensuse] need some ideas - traffic appears to be disappearing
On Wed, Jul 10, 2013 at 9:43 AM, Per Jessen <per@xxxxxxxxxxxx> wrote:

I am having some trouble with a new system I'm setting up. It's
essentially a clone of a node of an existing cluster, except
the new node is running openSUSE 12.3, the old ones openSUSE 11.0.

Inbound TCP traffic doesn't seem to work, so I've been debugging
this for a while. I have a postfix daemon listening on port 25,
but when I try to telnet to it, nothing happens.

I've set up the following iptables rules:

iptables -A PREROUTING -t mangle -i ipip1 -j LOG --log-level debug
--log-prefix 'prerout: '
iptables -A INPUT -p all -i ipip1 -j LOG --log-level debug --log-prefix
'input: '
iptables -A FORWARD -p all -i ipip1 -j LOG --log-level debug --log-prefix
'forward: '

I only get the message logged in PREROUTING, nothing in INPUT
nor FORWARD. What is happening to my message???

Note:

a) when I telnet from an external address (desired), the message
disappears.
2) if I telnet from a local (10.7.2.x) address (contrived), the message
appears.

Does this ring a bell with anyone? I feel I'm missing some tiny setting
somewhere.

I setup postfix on a 12.3 box recently (2 days ago?) and had the same
port 25 issue. (local telnet worked, remote showed nothing). I wish I
took better notes!

I think netstat -an showed a proper listener, so I was confused.

I found Yast created broken main.cf configs, so I think I fixed it by
editing the main.cf directly? I think it was the mydestination line.

I can say at some point it started to work and I haven't had a problem since.

I don't think my issue was a firewall issue, even though it sure
seemed to be one.

fyi: I don't have dovecot working yet. One problem at a time and I
had to put email setup on the back burner for a couple days.

Greg
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References