Mailinglist Archive: opensuse (686 mails)

< Previous Next >
[opensuse] IMAP issues on openSUSE 12.3
  • From: Roger Oberholtzer <roger@xxxxxx>
  • Date: Mon, 01 Jul 2013 13:31:21 +0200
  • Message-id: <1372678281.4652.8.camel@acme>
I am trying to get IMAPd running on openSUSE 12.3. At this point, I just
want it to serve $HOME/Maildir folders to clients like evolution on
localhost.

Oddly, I had it working. I decided to do a reboot to ensure that
everything came back. It did not.


# rccourier-imap status
Checking for Courier-IMAP


running
courier-imap.service - LSB: Courier-IMAP server
Loaded: loaded (/etc/init.d/courier-imap)
Active: active (running) since Mon, 2013-07-01 13:17:19 CEST; 2min 2s
ago
Process: 4387 ExecStop=/etc/init.d/courier-imap stop (code=exited,
status=0/SUCCESS)
Process: 4408 ExecStart=/etc/init.d/courier-imap start (code=exited,
status=0/SUCCESS)
CGroup: name=systemd:/system/courier-imap.service
├ 4422 /usr/sbin/courierlogger -pid=/var/run/imapd.pid -start
-name=imapd /usr/lib/courier-imap/couriertcpd -address=127.0.0.1 -maxprocs=40
-maxperip=20 -nodnslookup -noidentlookup 143 /usr/sbin/imaplogin
/usr/sbin/imapd Maildir
└ 4423 /usr/lib/courier-imap/couriertcpd -address=127.0.0.1
-maxprocs=40 -maxperip=20 -nodnslookup -noidentlookup 143 /usr/sbin/imaplogin
/usr/sbin/imapd Maildir

Jul 01 13:17:19 acme systemd[1]: Starting LSB: Courier-IMAP server...
Jul 01 13:17:19 acme courier-imap[4408]: Starting Courier-IMAP ..done
Jul 01 13:17:19 acme systemd[1]: Started LSB: Courier-IMAP server.
Jul 01 13:17:36 acme imapd[4422]: Connection, ip=[::ffff:127.0.0.1]
Jul 01 13:17:37 acme imapd[4422]: (null): TOO MANY CONSECUTIVE PROTOCOL
VIOLATIONS
Jul 01 13:17:37 acme imapd[4422]: Connection, ip=[::ffff:127.0.0.1]
Jul 01 13:17:49 acme imapd[4422]: LOGIN, user=roger, ip=[::ffff:127.0.0.1],
port=[56977], protocol=IMAP
Jul 01 13:17:58 acme imapd[4422]: LOGOUT, user=roger, ip=[::ffff:127.0.0.1],
headers=0, body=1591, rcvd=712, sent=60088, time=9



When evolution starts, I see that a imapd(143)/localhost port connection
is made. evolution then complains:

(evolution:4441): evolution-mail-WARNING **: Failed to refresh folder:
folder://1366192940.32174.4%40acme.pacific/INBOX/Customers/Acciona/DIAGOMED:
IMAP command failed: Error in IMAP command received by server.
(more of these...)
(evolution:4441): evolution-mail-WARNING **: Failed to refresh folder:
folder://1366192940.32174.4%40acme.pacific/INBOX/Customers/Applanix: Server
unexpectedly disconnected: Fatal error: TOO MANY CONSECUTIVE PROTOCOL
VIOLATIONS:


Also, when I give evolution the password for imap (current user's
password on localhost) it complains that the password is wrong. Which it
is not.

I am not using ssl, and passwords are not encrypted. The various log
files I have looked at did not shed any light.

I am curious why the IP address in the status listing is
[::ffff:127.0.0.1] and not [127.0.0.1

Odd that it worked before a reboot.]

It is sooo long since I last set up an openSUSE machine for this that I
have certainly forgotten something...

--
Roger Oberholtzer

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups