Mailinglist Archive: opensuse (1239 mails)

< Previous Next >
Re: [opensuse] btrfs fsck at boot??
Ken Schneider - openSUSE said the following on 06/27/2013 09:33 AM:
On 06/27/2013 07:57 AM, Anton Aylward pecked at the keyboard and wrote:
Over the w/e I converted my 12.2 desktop to 12.3 by the 'change the
repository and zypper up' method. A few problems with kde4 that I don't
think have to do with me - more n that later.


You need to use "zypper dup" to change distributions NOT "zypper up".

Ah.

# zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

Problem: libfolks-eds25-0.8.0-2.1.1.i586 requires libedataserver-1.2.so.17, but this requirement cannot be provided
uninstallable providers: libedataserver-1_2-17-3.6.3-1.2.1.i586[openSUSE_12.3-1.7]
libedataserver-1_2-17-3.6.3-1.2.1.i586[repo-12.3-oss]
libedataserver-1_2-17-3.6.3-1.5.1.i586[repo-12.3-update]

libedataserver-1_2-17-3.6.4-1.11.1.i586[repo-12.3-update]
Solution 1: keep obsolete libfolks-eds25-0.6.9-2.1.2.i586
Solution 2: do not forbid installation of evolution-data-server-3.6.4-1.11.1.i586[repo-12.3-update]
Solution 3: do not forbid installation of evolution-data-server-3.6.3-1.5.1.i586[repo-12.3-update]
Solution 4: do not forbid installation of evolution-data-server-3.6.3-1.2.1.i586[repo-12.3-oss]
Solution 5: do not forbid installation of evolution-data-server-3.6.3-1.2.1.i586[openSUSE_12.3-1.7]
Solution 6: break libfolks-eds25-0.8.0-2.1.1.i586 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/4/5/6/c] (c):

I'm running KDE. Not Gnome.
My email is read via Thunderbird.
Not Evolution.
I don't want Evolution.
I don't want Telepathy.

So I remove libfolks-eds25.

Not for a 'up" I get a huge pile of stuff anfd what bothers me is this:


The following packages are going to be downgraded:
ca-certificates-mozilla ffmpeg gdb gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-farstream gstreamer-0_10-plugins-ugly kde4-kgreeter-plugins kdebase4-workspace
kdebase4-workspace-debuginfo kdebase4-workspace-ksysguardd kdebase4-workspace-liboxygenstyle kdebase4-workspace-plasma-calendar kdelibs4 kdelibs4-core kdm kdm-branding-upstream
ksshaskpass kwebkitpart kwebkitpart-debuginfo kwebkitpart-lang kwin liba52-0 libalkimia4 libavcodec54 libavdevice54 libavfilter3 libavformat54 libavutil51 libdca0 libexif12
libfaac0 libfaad2 libfarstream-0_1-0 libfreebl3 libHUpnp1 libjpeg8 libkde4 libkde4-debuginfo libkdecore4 libkgapi0 libksuseinstall1 libkvkontakte1 libmad0 libmp3lame0
libmpeg2-0 libmpeg2convert0 libopencore-amrnb0 libopencore-amrwb0 libopenssl1_0_0 libopus0 libpostproc52 libqoauth1 libQtSolutions_SOAP-2_7-1 libraw5
libreoffice-templates-presentation-layouts libsoftokn3 libswresample0 libswscale2 libtwolame0 libupnp6 libvlc5 libvlccore5 libvpx1 libx264-125 libxvidcore4 MozillaFirefox
mozilla-kde4-integration nepomuk-core openssl plasma-addons plasma-addons-lancelot plasmoid-quickaccess polkit-kde-agent-1 polkit-kde-kcmmodules-1 python-kdebase4
python-simplejson ristretto ristretto-lang rubygem-rack-1_1 rubygem-rdoc smartmontools twolame vlc vlc-codecs vlc-noX vlc-qt xfce4-mixer xfce4-mixer-lang
xfce4-panel-plugin-mixer xine-ui xorg-x11-Xvnc

Why oh why oh why jsut converting from 12.2 to 12.3 and I regressing in the same KDE and other stuff?

Am I to tkae it that patches have been applied to 12.2 that haven't been applied to 12.3? That the 12/3 isn't being rebuilt/

WTF is going on here that all that stuff should regress?






--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >