Mailinglist Archive: opensuse (1239 mails)

< Previous Next >
Re: [opensuse] radeon crashes
On Monday 17 of June 2013 13:52:32 Peter wrote:
I'm trying to resolve long-running radeon issues (a laptop with a
Mobility Radeon 9700, based off the 9600, RV350), going back to around
the introduction of KMS in openSUSE 11.3 (i.e. years ago). On fresh
installs of all openSUSE versions since then, things run fine for maybe
a few days, then I get an issue where the screen momentarily blanks and
comes back but everything's frozen. Occasionally other weird artefacts
like the whole display gradually changing to rainbow vertical lines
occurs. Only a Magic Keys reboot can get me out.

I can confirm it isn't likely to be a faulty card as I experienced
exactly the same issues on a very different desktop system that had a
radeon 9600 AGP card. In all cases I'm using the default 'radeon' driver
pre-selected at install, since the ATI proprietary driver support for
this card was dropped years ago.

I have a system on oS 12.3 with a radeon 9600XT card that works fine, albeit a
little slowly at times.

The only workaround I've ever found is to disable hardware acceleration
in the 50-device.conf file.

I've started and contributed to various forum posts about this over the
years but they all went stale and none of the suggestions helped. I've
also contributed to Bugzilla reports that got closed and 'fixed' for
certain others but not me, so I recent started another of my own here
(currently no response):
https://bugzilla.novell.com/show_bug.cgi?id=817528

Is there anything else I can try or is it really the end of the road for
my legendary laptop?

You may try using the latest kernel from repository kernel:HEAD and report
this at bugs.freedesktop.org if it persists.

Regards,
Peter
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
References