Mailinglist Archive: opensuse (1239 mails)

< Previous Next >
Re: [opensuse] Re: XFS and openSUSE 12.1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 2013-06-11 13:16, Roger Oberholtzer wrote:
Despite being quiet on this, we have not solved the problem. We
have:

* Tried other file systems (e.g., ext4) * Tried faster
"server-grade" SATA disks. * Tried SATA3 interface as well as
SATA2.

The same thing happens. Periodically, write calls are blocking for
4-5 seconds instead of the usual 20-30 msecs.

Ah, thus not XFS related.


I have seen one unexpected thing: when running xosview during all
this, the MEM usage shows the cache use slowly growing. The machine
has 32 GB of RAM. The cache use just grows and grows as file file
system is written to. Here is the part I don't get:

Ok, as I understand it, it caches what you write in case something
wants to read it again. Applications do not matter. Syncing does not
matter, you may still want to read it again. And it grows while there
is memory to grow it. Then I assume the older blocks get replaced with
new contents.

I do not know how to limit it, or tell the system not to cache certain
operations. I think I remember the xine people talking of using raw
read operations to avoid caching - caching a dvd video while playing
makes no real sense as you only read it once. maybe you can do the same.



Did the XFS people say something yet? You said you were going to ask them.

- --
Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 "Dartmouth" at Telcontar)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlG3C5EACgkQIvFNjefEBxrVFgCg2brzPGctU810cDCCevhVrH7m
G4sAnA/BEBuM+odUQ+givYwxJgVqotrt
=ag5W
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread