Mailinglist Archive: opensuse (1231 mails)

< Previous Next >
Re: [opensuse] Root and boot partitions on a sw raid volume (opensuse 12.2 - 12.3 rc1 64bit)
  • From: jjletho <jjletho67-esus@xxxxxxxx>
  • Date: Thu, 21 Mar 2013 18:59:49 +0100
  • Message-id: <514B4A95.20203@yahoo.it>


In my opinion there are two different problem:

I'm going to wait for the 12.3 final release and, if the behavior
will be the same i'll open a bugreport I have already tried 12.3 rc2
with no luck

I wouldn't expect any such major changes. Maybe you could try 12.2
and see how that goes.

I've already tried :-)

12.2
12.3rc1
12.3rc2

All this versions exhibit a very similar behavior

I guess you have already googled - "opensuse grub2 raid" ? Personally I
would suspect something in the grub config.


I have just tested OpenSuse 12.3 final release and it exhibits the same
behavior.

I've done several tests and analysis and i guess there are, in my opinion,
two distinct but interconnected problem which i'm going to summarize here:


-Opensuse 12.3 final.
-Installation through yast
-partition layout (implemented through yast during the installation):

/boot -> /dev/md0 (raid1) -> sda1, sdb1
swap -> /dev/md1 (raid1) -> sda2,sdb2
/ -> logvol1 -> volgroup1 -> /dev/md2 -> sda3,sdb3
/home -> logvol2 ->volgroup1 -> /dev/md2 -> sda3,sdb3
/tmp -> logvol3 -> volgroup1 -> /dev/md2 -> sda3,sdb3
/var -> logvol4 -> volgroup1 -> /dev/md2 -> sda3,sdb3
sda4,sdb4 unformatted

Bootloader Grub2 -> MBR

By this way i obtain an unbootable system with at least two major problems:

1) grub2 is installed only on the first disk
2) /dev/md0 (which is mounted as /boot) is not correctly initialized and, at
first reboot, only /dev/sdb1 is active part of the raid volume.


The system is not bootable because grub expects to find its files and
the kernel on /dev/sda1 which is empty. I recovered from this situation
booting from the recovery cd and issuing this command to hotadd /dev/sda1 to
/dev/md0. I waited until the synchronization was completed and then the system was able to boot

Note that /dev/sda1 was already initialized as part of /dev/md0 but not
synced by yast installer

In the case /dev/sda is failed the system cannot boot from /dev/sdb.
This is due the lack of installation of GRUB on /dev/sdb mbr.

I Issued a grub2-install /dev/sdb without touching the grub config and the system was able to boot also with the first disk pulled out.

I'm going to open a bug for this. Of course i'm not sure the workarounds i described are reliable enough. For example whats happen after a kernel update ? (What will happen after perl-bootloader is called ?)I find the configuration scripts of grub2 really cryptic, i can't honestly say if they are correctly configured!


Any comments or similar experiences are welcome
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups