Mailinglist Archive: opensuse (1231 mails)

< Previous Next >
Re: [opensuse] No ACPI power off with openSuSE 12.2 / kernel 3.4 - SOLVED
On 02/25/2013 02:28 PM, Patrick Shanahan wrote:
* upscope <upscope@xxxxxxx> [02-25-13 13:11]:
[...]
Sorry to say in my system there is no reference to acpi or apm in the
default line.

[CODE]

GRUB_CMDLINE_LINUX_DEFAULT=" video=1920x1080x16
resume=/dev/disk/by-id/ata- ST31000528AS_6VPEXG0E-part1 splash=silent
quiet showopts"

GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off
powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset
x11failsafe" [/CODE]

Guess I can try removing it from the grub cmdline for recovery and see
what happens.
If you don't boot the "RECOVERY" set, changes will not effect, and your
"DEFAULT" doesn't contain those settings now so likely you will see no
difference.

You *might* try adding "acpi=on apm=on", just a stab-in-the-dark.

This is interesting. Over the past few months I've noticed that my 12.2-64
desktop would go into a suspend/hibernate/? mode overnight. It required
lots of pounding on the keyboard, clicking mouse buttons, and a long time
to wake the box up. Sometimes it appeared to be hung and required a
power-off reboot cycle.

Then, a few weeks ago after a zypper dup I noticed that the monitor save-screen
thing would turn off the monitor after four minutes regardless of the "Configure
Desktop" setting.

So I tried Patrick's suggestion of adding "acpi=on apm=on"to /etc/default/grub.
There was no mention of acpi/apm in the file initially. That seems to have
fixed
both of my issues! So this may be a good thing for me to do on all of the
openSuSE boxes I manage.

Regards,
Lew

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages