Mailinglist Archive: opensuse (770 mails)

< Previous Next >
Re: [opensuse] Where can I get instructions for compiling VirtualBox?
  • From: <j.e.perry@xxxxxxx>
  • Date: Wed, 15 Aug 2012 22:06:10 -0400
  • Message-id: <20120815220610.Y18KW.1240020.imail@eastrmwml113>

---- j.e.perry@xxxxxxx wrote:

---- Mark Misulich <munguanaweza@xxxxxxxxx> wrote:
On Mon, 2012-08-13 at 23:01 -0400, j.e.perry@xxxxxxx wrote:


Hi,
you can download an rpm for Opensuse 11.4/12.1 from this page.

https://www.virtualbox.org/wiki/Linux_Downloads



So I tried this, since I'd already gotten Mark's message and downloaded the rpm
before I got Werner's message. I tried from both Konqueror, letting it send
the file to apper, and from yast. Same result both times: a hanging alert box
saying "waiting for server to start" and a field saying "license agreement
required".

Next, I tried from the command line (now obvious why neither K nor Yast worked):

-----------------------------------------------------------------------------------------------------------------

linux-tana:/home/john/Documents/Software/Virtualbox # zypper in
VirtualBox-4.1-4.1.18_78361_openSUSE114-1.x86_64.rpm
Retrieving repository 'VirtualBox for openSUSE 11.4' metadata [\]

New repository or package signing key received:
Key ID: 54422A4B98AB5139
Key Name: Oracle Corporation (VirtualBox archive signing key)
<info@xxxxxxxxxxxxxx>
Key Fingerprint: 7B0FAB3A13B907435925D9C954422A4B98AB5139
Key Created: Tue May 18 13:38:56 2010
Key Expires: (does not expire)
Repository: VirtualBox for openSUSE 11.4

Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?]
(r): a
Retrieving repository 'VirtualBox for openSUSE 11.4' metadata [done]
Building repository 'VirtualBox for openSUSE 11.4' cache [done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
VirtualBox-4.1 libpng12-0

2 new packages to install.
Overall download size: 1.0 MiB. After the operation, additional 137.5 MiB will
be used.
Continue? [y/n/?] (y):
Retrieving package libpng12-0-1.2.49-9.9.1.x86_64 (1/2), 72.0 KiB (168.0 KiB
unpacked)
Retrieving: libpng12-0-1.2.49-9.9.1.x86_64.rpm [done (62.2 KiB/s)]
Retrieving package VirtualBox-4.1-4.1.18_78361_openSUSE114-1.x86_64 (2/2),
963.0 KiB (137.4 MiB unpacked)
Installing: libpng12-0-1.2.49-9.9.1 [done]
Retrieving package VirtualBox-4.1-4.1.18_78361_openSUSE114-1.x86_64 (1/2),
963.0 KiB (137.4 MiB unpacked)
Installing: VirtualBox-4.1-4.1.18_78361_openSUSE114-1 [error]
Installation of VirtualBox-4.1-4.1.18_78361_openSUSE114-1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
unpacking of archive failed on file /usr/lib/virtualbox/VBoxDD.so;502c5185:
cpio: read failed - Bad file descriptor
error: VirtualBox-4.1-4.1.18_78361_openSUSE114-1.x86_64: install failed



Abort, retry, ignore? [a/r/i] (a): r

-----------------------------------------------------------------------------------------------------------------

Bad package? or what?

While I'm waiting to hear from someone, I'll go ahead and try to sort through
the two-dozen VB packages in Werner's reference. (or, if someone can give me
some guidance...:-)

jp

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References