Mailinglist Archive: opensuse (770 mails)

< Previous Next >
Re: [opensuse] Enigmail fails to sign posts (12,1)
On 2012-08-07 12:47, Wolfgang Rosenauer wrote:
Am 07.08.2012 12:40, schrieb Carlos E. R.:
I get this error when attempting to send and sign:


+++························
OpenPGP Alert

Send operation aborted.

Key 0xEB267D05 not found or not valid. The (sub-)key might have expired.

gpg command line and output:
gpg
No protocol specified
xprop: unable to open display ':0.0'
No protocol specified

(pinentry-gtk-2:6432): Gtk-WARNING **: cannot open display: :0.0
gpg-agent[6431]: can't connect to the PIN entry module: End of file
gpg-agent[6431]: command get_passphrase failed: No pinentry
gpg: problem with the agent: No pinentry
^^^^^^^^^^^
(pinentry-gtk-2:6432): Gtk-WARNING **: cannot open display: :0.0

But pinentry is indeed installed.


pinentry-gtk cannot open a display. So you cannot enter your passphrase
and everything fails.
The issue seems to sit deeper than enigmail.

Any idea how to solve that?

I have tried to tell enigmail NOT to use the agent, to no avail.


I see that there is no agent running in the session, even though the session
properties specify that
the gnome kyering: gpg agent is set to start.
Gnome keyring is installed.

When I start the session I see in the log

+++························

Aug 7 12:44:53 bombadillo gnome-keyring-daemon[6828]: The GPG agent was
already initialized
Aug 7 12:44:53 bombadillo gnome-keyring-daemon[6828]: The SSH agent was
already initialized
Aug 7 12:44:53 bombadillo gnome-keyring-daemon[6828]: The PKCS#11 component
was already initialized

························++-


But "ps afxu | grep -i agent" shows only:

+++························
cer@bombadillo:~> ps afxu | grep -i agent
cer 7916 0.0 0.0 8048 856 pts/2 S+ 13:01 0:00 |
\_ grep --color=auto -i agent
cer 7083 0.0 0.0 181960 5536 ? Sl 12:44 0:00
/usr/lib/polkit-gnome-authentication-agent-1
cer@bombadillo:~>
························++-


Much earlier I see (I have started the session several times):

+++························

Aug 7 12:40:45 bombadillo gnome-keyring-daemon[5537]: unsupported key
algorithm in certificate:
1.2.840.10045.2.1
Aug 7 12:40:45 gnome-keyring-daemon[5537]: last message repeated 4 times
Aug 7 12:40:45 bombadillo gnome-keyring-daemon[5537]: couldn't parse
certificate data
Aug 7 12:40:45 bombadillo gnome-keyring-daemon[5537]: couldn't parse
certificate(s):
/etc/ssl/certs/README.RootCerts

························++-

So maybe there is a certificate it does not like, but that daemon is running.




--
Cheers / Saludos,

Carlos E. R.
(from 12.1 "Asparagus" GM (bombadillo))

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups