Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] OpenSuSE 12.1 and netxen firmware incompatibility
Il 19/07/2012 18:04, claudioml@xxxxxxxxxxxxxxxx ha scritto:
Hello all,

Into a new server, i have 2 quad port ethernet. At boot time, the system
says to me:

netxen_nic 0000:0e:00.0: Incompatibility detected between driver and
firmware version on flash. This configuration is not recommended. Please
update the firmware on flash immediately

lspci -v output:

0b:00.0 Ethernet controller: NetXen Incorporated NX3031 Multifunction
1/10-Gigabit Server Adapter (rev 42)
Subsystem: Hewlett-Packard Company NC375T PCI Express Quad Port
Gigabit Server Adapter
Flags: bus master, fast devsel, latency 0, IRQ 31
Memory at fb600000 (64-bit, non-prefetchable) [size=2M]
[virtual] Expansion ROM at e7200000 [disabled] [size=64K]
Capabilities: [40] MSI-X: Enable+ Count=64 Masked-
Capabilities: [80] Power Management version 3
Capabilities: [a0] MSI: Enable- Count=1/32 Maskable- 64bit+
Capabilities: [c0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 59-69-46-61-6e-48-73-75
Kernel driver in use: netxen_nic

0b:00.1 Ethernet controller: NetXen Incorporated NX3031 Multifunction
1/10-Gigabit Server Adapter (rev 42)
Subsystem: Hewlett-Packard Company NC375T PCI Express Quad Port
Gigabit Server Adapter
Flags: bus master, fast devsel, latency 0, IRQ 31
Memory at fb400000 (64-bit, non-prefetchable) [size=2M]
Capabilities: [40] MSI-X: Enable+ Count=64 Masked-
Capabilities: [80] Power Management version 3
Capabilities: [a0] MSI: Enable- Count=1/32 Maskable- 64bit+
Capabilities: [c0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 59-69-46-61-6e-48-73-75
Kernel driver in use: netxen_nic

Ethtool output:

ethtool -i eth11
driver: netxen_nic
version: 4.0.76
firmware-version: 4.0.544
bus-info: 0000:0e:00.3
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes

Now, my questions are:
- that warning is dangerous? It's better to upgrade firmware?
- And, if i have to upgrade firmware, someone can give to me an
indication from where to start to do this upgrade without risks ? I have
tryied with the DVD rom of firmware upgrade of HP, but i think the
version is the same as that current......

Thanks in advance,

Claudio Prono.

No one have experienced that problem?

Claudio.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >