Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] GNOME:Stable:3.4 on openSUSE 12.2
On 07/19/2012 01:55 PM, Roger Oberholtzer wrote:
For a while the evolution app in openSUSE 12.1 has been failing. I have used
other readers while waiting for a fix.

I decided that perhaps a better solution was to add GNOME:/STABLE:/3.4/ and see
what that evolution does.

Perhaps not one of my better solutions. Aside from evolution still not starting
(for apparently different reasons), things like ConsoleKit are now failing. I
get a popup message when logging in to KDE about this. So, networking and other
things are now broken.

I see that a common complaint is that there are undefined symbols. For example,
one of the libraries that was updated is:

/usr/lib/libpolkit-gobject-1.so.0

and it complains that g_mutex_lock is not defined. This file comes from
libpolkit0, which was built July 2. So I would think some other person would
have experienced any obvious problem.

The symbol comes from glib2. In 12.1 you have glib 2.30, in STABLE:/3.4 there is 2.32 and it appears to be needed

Specifically libglib-2_0-0-2.32

And if you update glib you most likely have to update gtk too. I'm surprised this wasn't dealt with automatically by dependencies. Did you force the installation somehow? If not, it's a definite bug

Anders
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References