Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] bind DNS: forwarders not working unless named is restarted
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Tue, 03 Jul 2012 12:11:47 +0200
  • Message-id: <jsugh3$f6f$2@saturn.local.net>
lynn wrote:

On 03/07/12 11:01, Ruediger Meier wrote:
On Monday 02 July 2012, lynn wrote:


But I have to restart named for the forwarders to kick in. I've
tried enabling

You mean it does not work right after reboot?
I've had similar problems in past because of several reasons, for
example if network setup was not really completed before starting
named. I thought I got everything solved but yesterday I noticed
again a broken named on one of my 11.4 boxes. Maybe the latest bind
update two weeks ago did something bad?

Anyway to avoid problems with incomplete network setup etc. you could
do RUN_PARALLEL="no"
in /etc/sysconfig/boot (requires sysvinit). Then see whether the
problem still persists.

cu,
Rudi

Hi Rudi
This is 12.1 systemd with:
rpm -q bind
bind-9.8.1P1-4.11.1.i586
and ls -l /usr/sbin/named
-rwxr-xr-x 1 root root 560484 Jun 5 12:17 /usr/sbin/named
June 5th.

I've tried putting
rcnamed restart
in
/etc/boot.local
but it seems that the network is still not up when boot.local is run.
ifup eth1
rcnamed restart
is a little more reliable, but I need something where someone can just
press the switch and reboot without me having to be called out.

I can't risk changing to sysvinit until we get some downtime, August
maybe.

Is this too minor an issue for a buzilla?
L x

If bind _genuinely_ requires the network to be up to complete start-up
but doesn't wait for the network, yes, that is a bug. The fix would
appear to be to amend <something> in the systemd service file to make
bind wait for the network to be started.



--
Per Jessen, Zürich (18.1°C)

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References