Mailinglist Archive: opensuse (818 mails)

< Previous Next >
Re: [opensuse] bind DNS: forwarders not working unless named is restarted
On Monday 02 July 2012, lynn wrote:
Hi
12.1 in HA setup with 2 DNS corresponding to two replicating DC's.
DC1 192.168.1.2, DC2 192.168.1.3

Our internal zones are loaded fine after boot, but hitting any of
the forwarders pointing out to Internet fails. Here is the line in
/etc/named.conf on DC1:
forwarders { 217.70.240.135; 217.70.70.136; 192.168.1.3 };
and on DC2:
forwarders { 217.70.240.135; 217.70.70.136; 192.168.1.2 };

Both the forwarders are online and nslookup-able e.g.:
lynn@hh1:~> nslookup

> 217.70.240.135

Server: 192.168.1.2
Address: 192.168.1.2#53

Non authoritative answer:
135.240.70.217.in-addr.arpa name = dns1.dragonet.es.

Authoritative answers can be found from:
240.70.217.in-addr.arpa nameserver = dns1.dragonet.es.
240.70.217.in-addr.arpa nameserver = dns2.dragonet.es.
dns1.dragonet.es internet address = 217.70.240.135
dns2.dragonet.es internet address = 217.70.240.136

But I have to restart named for the forwarders to kick in. I've tried
enabling

You mean it does not work right after reboot?
I've had similar problems in past because of several reasons, for
example if network setup was not really completed before starting
named. I thought I got everything solved but yesterday I noticed again
a broken named on one of my 11.4 boxes. Maybe the latest bind update
two weeks ago did something bad?

Anyway to avoid problems with incomplete network setup etc. you could do
RUN_PARALLEL="no"
in /etc/sysconfig/boot (requires sysvinit). Then see whether the problem
still persists.

cu,
Rudi
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References