Mailinglist Archive: opensuse (1445 mails)

< Previous Next >
Re: [opensuse] Thunderbird 11.99-2.1 on oS12.1
Hi,

Am 20.03.2012 13:35, schrieb Andrea Turrini:
Dear all,

I have just updated thunderbird to version 11.99-2.1 (from repo
Mozilla:Beta) and now I have no more sound notifications when new mail
arrives.
If I revert to the previous version (11.0-3.1 from the Mozilla repo),
I have sound notification.

The problem occurs with both system sound and custom sound. If I try
to play the custom sound using the button near "Browse", I obtain no
sound.

Is this a known problem?

Thanks for testing the stuff actually and even more for reporting issues
you see. ;-)

Do you have libcanberra0 installed?
If not, please do so and report back if it works. If so, it's somehow
expected (not really a bug though).

Background:
Mozilla apps used to use libesd from esound for a decade or so but this
is more or less obsolete now with pulseaudio etc.
Starting with Thunderbird 12 (and Firefox 12 fwiw) they use libcanberra
for that sound output (canberra was already used for menu sounds as
configured in Gnome soundthemes for example).

For upcoming packages I already added
Recommends: libcanberra0
because of that.

I refrained from using Requires for now because it's an optional
dependency. Note that libesd never was a hard requirement too.


Wolfgang
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References