Mailinglist Archive: opensuse (1698 mails)

< Previous Next >
Re: [opensuse] systemd pam entry missing in /etc/pam.d/xdm
* Adam Tauno Williams <awilliam@xxxxxxxxxxxxx> [12-29-11 16:12]:
On Thu, 2011-12-29 at 09:45 -0500, Patrick Shanahan wrote:
* Adam Tauno Williams <awilliam@xxxxxxxxxxxxx> [12-29-11 09:42]:
On Wed, 2011-12-28 at 15:30 -0500, Patrick Shanahan wrote:
My local observances follow yours :^(
add: a laptop w/12.1 as original install, not upgrade, also does not
work
automagically for removable media.
Have you run "udisks --monitor" to see if any events are generated with
you swap media?
<http://lists4.suse.de/opensuse-gnome/2011-12/msg00032.html>
09:43 Crash: ~ > udisks --monitor
Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
changed: /org/freedesktop/UDisks/devices/sdf
changed: /org/freedesktop/UDisks/devices/sdf
added: /org/freedesktop/UDisks/devices/sdf1

Then you get more than me. :(

Have found "udisks-glue" that *will* automagically mount optical and usb
devices, but cannot make it provide <user> access. Seems to require root
privileges, which is no better than using pmount and providing the
/dev/... for it.

My config for udisks-glue:

#
# Filters
#

filter disks {
optical = false
partition_table = false
usage = filesystem
}

filter burnable {
optical = true
optical_disc_closed = false
}

filter optical {
optical = true
}

#
# The default entry (only used if no filters match)
#

default {
post_insertion_command = "insertion-notify %device_file"
}

#
# Additional entries
#


match disks {
automount = true
automount_options = { sync, noatime }
post_mount_command = "mount-notify mounted %device_file %mount_point"
post_unmount_command = "mount-notify unmounted %device_file %mount_point"
}

match burnable {
post_insertion_command = "k3b %device_file"
post_mount_command = "mount-notify mounted %device_file %mount_point"
post_insertion_command = "udisks --mount %device_file --mount-options ro"
}

match optical {
automount = true
automount_options = ro
post_mount_command = "mount-notify mounted %device_file %mount_point"
post_insertion_command = "udisks --mount %device_file --mount-options ro"
}


====================

adding any of "group, user, users, gid=####" to "automount_options" seem
to stop the automounting process.

also tried adding:
post_insertion_command = "udisks -mount %devide_file --mount-options \
rr users"
in "match disks" below "automount_options"

:^(((



--
(paka)Patrick Shanahan Plainfield, Indiana, USA HOG # US1244711
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org openSUSE Community Member
Registered Linux User #207535 @ http://linuxcounter.net
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >