Mailinglist Archive: opensuse (1698 mails)

< Previous Next >
[opensuse] Laptop Networking Issue with 12.1
Hi Folks,

I have a rush job to install Linux on a new HP 4530s laptop, so
I tried 12.1 x86-64.

Things went well until the configuration screen right before the
"Test Network" screen. A popup appeared saying that the network
wasn't found and gave me an "ok" button to click. It then proceeded
to the network test screen. It failed the network test, obviously, but
proceeded with the installation if testing wasn't selected. Once the
install was finished I fiddled around a bit to see if I could figure out
what was going on. Ifconfig showed both the wired and wireless
interfaces, the wired interface even showed an outgoing byte count,
but zero in.

I tried configuring the wireless interface, it showed my access point
and allowed me to select security and the password, but data
couldn't be passed.

So, basically, all networking is down.

I then installed 11.4 x86-64 and it works with the wired interface! This
proves it's not the laptop, the cabling or my switched hub. But the
wireless interface doesn't work, it won't even show the access points.

I've got this weekend to fiddle with this, so I'd like to try 12.1 again
and try enabling sysvinit. This leads to the question: How can I
disable systemctl and enable sysvinit without a working network?
Is this even worth trying?

Or is there something else I can try?

For the record:

Laptop: HP 4530s
Ethernet: Realtek RTL8111/8168B
Wireless: Atheros AR9285
VGA: Intel 2nd Generation Core Processor Family (rev 09)

Thanks,
Lew

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >