Mailinglist Archive: opensuse (1658 mails)

< Previous Next >
Re: [opensuse] perl module install question
  • From: Craig Millar <craigmillar+opensuse@xxxxxxxxx>
  • Date: Wed, 7 Dec 2011 12:04:40 +0000
  • Message-id: <>
On 6 December 2011 21:17, Greg Freemyer <greg.freemyer@xxxxxxxxx> wrote:
I'm trying to install perl-IO-Compress from OBS, but it says I need perl

The strange thing is I have perl 5.14.2, so I'm confused.  If anyone
can tell me what's going on, I'd appreciate it.

Hmm, I am getting something similar, with the devel:languages:perl repo enabled:

root:~ # zypper in perl-Compress-Raw-Zlib
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: perl-Compress-Raw-Zlib-2.045-1.1.i586 requires perl = 5.14.2,
but this requirement cannot be provided
Solution 1: do not install perl-Compress-Raw-Zlib-2.045-1.1.i586
Solution 2: break perl-Compress-Raw-Zlib by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): c
root:~ # rpm -q perl

I downloaded the perl-Compress-Raw-Zlib rpm and tried to install
directly with rpm and got an error:

error: Failed dependencies:
perl-Compress-Raw-Zlib is obsoleted by (installed) perl-5.14.2-1.9.i586

I don't really have an answer I'm afraid, it appears to be something
to do with inconsistent packages in devel:languages:perl and you may
want to try CPAN as suggested by Dave if you can't wait for it to be
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups