Mailinglist Archive: opensuse (1786 mails)

< Previous Next >
Re: [opensuse] download.opensuse.org (Domain name not found) - "zypper up" fails after upgrade to 12.1
On Mon, 2011-11-28 at 14:26 -0500, zGreenfelder wrote:
On Sat, Nov 19, 2011 at 9:55 AM, Adam Tauno Williams
<awilliam@xxxxxxxxxxxxx> wrote:
I updated my perfectly working openSUSE 11.4 to 12.1, after which "zypper
up" fails and no repos on download.opensuse.org can be used -
linux-yu4c:~ # zypper up
Download (curl) error for
'http://download.opensuse.org/distribution/12.1/repo/oss/content':
Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org (Domain name
not found)
Abort, retry, ignore? [a/r/i/?] (a): ^Clinux-yu4c:~
# host download.opensuse.org
download.opensuse.org has address 195.135.221.134
download.opensuse.org has IPv6 address 2001:67c:2178:8::13
linux-yu4c:~ #
I've tried disabling IPv6 and using a different DNS server. What the ... ?
Another user, on a different network, has the same problem after upgrading.
interesting problem, did you find a solution? have you checked
/etc/nsswitch.conf for a line like:
hosts: files dns
my new install has ... well an odd entry I can't seem to copy here.
have you tried putting an entry in /etc/hosts (just as a test, it's
not a long term fix, of course) with the IP you pulled with the host
command?

I tried the /etc/hosts trick. It had no effect.

Still no resolution; on that network I cannot use zypper.




--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups