Mailinglist Archive: opensuse (1786 mails)

< Previous Next >
[opensuse] openSuse 12.1 - observations upon gnome3 and systemd
I am in the process of upgrading my oss machines from oss 11.4 to 12.1. Here are some comments that may help some others who run into issues similar to mine, and perhaps prompt some others to reply back with solutions.

1) systemd and loss of network: After upgrading, the machine would not start the network. ifconfig showed just lo. Interfaces all showed up fine and configured in Yast2. Doing a manual restart of the network (/etc/init.d.network restart) would produce a message stating "redirecting to systemd" and still no network. Manually bringing up interfaces with ifup (machine has 2 interfaces), would bring up interfaces, but doing a network restart (either via systemd or via /etc/init.d/network restart) would again take the network down. Reverting to sysV and dumping systemd (zypper in sysvinit-init) "fixed" the problem. This machine is a VM on top of vSphere 4,1, interfaces are vmxnet3 (2 interfaces), and interfaces are configured with static ips. Another machine I had upgraded to oss12.1 was physical with dhcp configured interfaces and that one works fine with systemd. For now, I am going to revert all machines to sysV.

2) gnome3: Upgrading to oss12.1 with gnome3 made gnome3 always fall back to gnome3's "fallback" mode when accessed via FreeNX. Same results when accessed via VNC. This machine is only used remotely. It worked fine with FreeNX and gnome2 for years. Gnome3's fallback mode is useless. KDE4 worked fine both via vnx and FreeNX, as did xfce. I left the machine with xfce.

Regards,

--
--Moby

They that can give up essential liberty to obtain a little temporary safety
deserve neither liberty nor safety. -- Benjamin Franklin

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups