Mailinglist Archive: opensuse (1690 mails)

< Previous Next >
Re: [opensuse] webcam video dark, maybe wrong driver?
On 11/01/2011 03:38 PM, C wrote:
On Tue, Nov 1, 2011 at 02:20, George OLson<grglsn765@xxxxxxxxx> wrote:
I have an A4Tech PK-720G webcam plugged into my USB port. It has a built in
microphone. I managed to get skype to pick up the camera microphone input
(using pulse audio manager), and the video works to some degree, but it
shows a very dark image even when I am in a very well-lighted room.

Skype says it is using A4TECH USB2.0 PC CAMERA J(/dev/video0)

If I run lsusb, the third line shows the following:

Bus 001 Device 002: ID 0ac8:c40a Z-Star Microelectronics Corp.

Also, the lines related to video when I run lsmod show the following:

uvcvideo 70281 0
videodev 81448 1 uvcvideo
v4l1_compat 17505 2 uvcvideo,videodev
v4l2_compat_ioctl32 10573 1 videodev

I don't really know what those indications mean, and I am kind of at a loss
as to what to do next. I google searched for a driver that linux can use
with this camera and couldn't find anything.

How do I find a correct driver for this camera and what do I need to tweak
to make it work right?


Well, to start with that camera uses UVC, so in theory it should "just
work" using the UVC drivers already installed on your computer.
But... I don't see that specific device (0ac8:c40a) here:
http://www.ideasonboard.org/uvc/ not that that really means
anything... in most cases any UVC compliant webcam should "just work"
in Linux these days.

In other digging, it seems that webcams with that device ID are
working... for example:
http://www.lavrsen.dk/foswiki/bin/view/Motion/RetailPlus

Have you tried it with another app like Kopete, Cheese etc?

You didn't say what version of openSUSE (and kernel) you're using...
that can have an impact, especially if you're using an older kernel.

C.

I am using openSUSE 11.4 and kernel 2.6.37.6-0.7-desktop. Per your suggestion, I just tried the camera with Kopete and Cheese, and they both also portray a very dark image even though the room is well lighted. I also have another webcam application, wxCam, and it also portrays a very dark image.

However, the application webKam does not detect the camera at all.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
References