Mailinglist Archive: opensuse (714 mails)

< Previous Next >
[opensuse] Tearing my hear out - mail server malfunction
Hi all. I run a local mail server with a fairly standard setup:

Fetchmail -> sendmail ->procmail -> spamd -> Maildir -> dovecot IMAP.

Everything worked fine until around 1345 local time Sunday. Ever since then,
fetchmail has been dumping all mail into /var/spool/mail/<username> and there
it stays. The rest of the chain isn't firing. procmail is configured to write
to a log file in my home directory (pm.log) and that is not being written.

Nothing has been written to /var/log/mail since August 28th (when I upgraded
to oS 11.4) so that is no help.

I have tried logging out of KDE and even restarting the machine (which I
rarely do - uptimes of >180 days are not uncommon) but to no avail. I'm
completely stumped as to why it was working fine and then suddenly stopped
with no intervention. I haven't even installed any updates in the last week or
so.

I'd appreciate any pointers as to where to look next. Fetchmail is working
fine, as I said, but nothing gets past /var/spool/mail/<username>. When it was
working fine, nothing went into this directory, let alone stayed there. What
has broken and why? (Yes, I know that is an almost impossible question but at
least if I knew where to look it would help).

ps -eaf | grep 'mail' says:

root 4501 1 0 Oct09 ? 00:00:01 sendmail: accepting
connections
110 5765 1 0 18:22 ? 00:00:00 /usr/bin/fetchmail -d 90 -a -f
/etc/fetchmailrc -L /var/log/fetchmail
user 6023 5805 0 18:33 pts/0 00:00:00 grep mail
mail 8214 1 0 Oct09 ? 00:00:00 sendmail: Queue control

mail 8215 8214 0 Oct09 ? 00:00:01 sendmail: running queue:
/var/spool/clientmqueue
use> 17700 17663 0 Oct09 ? 00:00:00
/usr/bin/akonadi_maildir_resource --identifier akonadi_maildir_resource_0
user 17701 17663 0 Oct09 ? 00:00:00
/usr/bin/akonadi_maildispatcher_agent --identifier
akonadi_maildispatcher_agent
user 21579 1 0 Oct09 ? 00:00:40 /usr/bin/kmail -caption KMail
user 21580 17538 0 Oct09 ? 00:00:05 kdeinit4: kio_imap4 [kdeinit]
imap local:/tmp/ksocket-user/klauncherT17539.slave-socket local:/tmp/ksocket-
user/kmaile21579.slave-socket
user 21581 17538 0 Oct09 ? 00:00:01 kdeinit4: kio_imap4 [kdeinit]
imap local:/tmp/ksocket-user/klauncherT17539.slave-socket local:/tmp/ksocket-
user/kmaily21579.slave-socket

Thanks in advance,
Rodney.
--
===================================================
Rodney Baker VK5ZTV
rodney.baker@xxxxxxxxxxxx
===================================================

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups