Mailinglist Archive: opensuse (1815 mails)

< Previous Next >
Re: [opensuse] Mobile broadband
  • From: Istvan Gabor <suseuser04@xxxxxxx>
  • Date: Mon, 05 Jul 2010 11:36:15 +0200
  • Message-id: <5aef17b9.527f5d85.4c31a78f.14a98@xxxxx>
2010. július 5. 9:17 napon Roger Oberholtzer <roger@xxxxxx> írta:

I have been trying to get mobile broadband working on my laptop. I tried
openSUSE11.2, and now 11.3. I have a certain amount of success. But no
final joy. I suspect it is my lack of knowledge that is the problem
here.

I am trying to use a Swedish service called "Comviq Surf" that provides
a USB modem. It is a per-day/week/month service, similar to what you get
in hotels for wireless. The modem is (from lsusb):

idVendor 0x12d1 Huawei Technologies Co., Ltd.
idProduct 0x1001 E620 USB Modem
bcdDevice 0.00
iManufacturer 2 HUAWEI Technology
iProduct 1 HUAWEI Mobile

There are some issues with this device presenting itself as a disk.
Happily, openSUSE contains the support to deal with this (unmount the
disk and then access the GSM modem part). After the devices is attached,
I see this in /var/log/messages:

NetworkManager: (ttyUSB0): new GSM device (driver: 'option1')
NetworkManager: (ttyUSB0): exported as
/org/freedesktop/NetworkManager/Devices/2
NetworkManager: (ttyUSB0): now managed
NetworkManager: (ttyUSB0): device state change: 1 -> 2 (reason 2)
NetworkManager: (ttyUSB0): deactivating device (reason: 2).
NetworkManager: (ttyUSB0): device state change: 2 -> 3 (reason 0)
NetworkManager: user_connection_get_settings_cb():
user_connection_get_settings_cb: Invalid connection: 'NMSettingGsm' /
'number' invalid: 2
NetworkManager: wait_for_connection_expired(): Connection (2)
/org/freedesktop/NetworkManagerSettings/1 failed to activate (timeout): (0)
Connection was not provided by any settings service
NetworkManager: wait_for_connection_expired(): Connection (2)
/org/freedesktop/NetworkManagerSettings/1 failed to activate (timeout): (0)
Connection was not provided by any settings service

Which looks like a mix of good and bad news. Given that I do not know
what 'reason 2' or 'reason 0' are, well, who is to say which type of
news this is. I do have this device:

crw-rw---- 1 root dialout 188, 0 2010-07-04 21:41 /dev/ttyUSB0

[snip]

Hello!

This won't be a real help, I am only writing about my very recent experience
with the same device.
Less than a weak ago I had to use Huawei E220 (I guess this is the same as as
yours in the device info, at least very similar) with Ubuntu 10.4 with gnome
and networkmanager. The device either was not recognized as modem, only as
cdrom, or if it was recognized the connection did not work. I remembered that
in previous Ubuntu it worked out of the box. So I tried it with a live Ubuntu
9.04 CD and it did work, I only had to accept the default values the system had
offered, I had not change phone number, login, password, nothing, and it made
the connection. I don't know about this device and opensuse anything as I never
tried it in opensuse (the device is not mine), but I guess that recent systems
use some newer software in which something has been changed so that they can
not use the device anymore. On the Ubuntu forums you can find several threads
related to this issue. A few examples:


https://bugs.launchpad.net/ubuntu/+source/linux/+bug/546728
https://bugs.launchpad.net/ubuntu/+bug/592564

FInaly, maybe this link helps or has some useful info:
http://www.betavine.net/bvportal/resources/datacards/os/suse

Istvan




--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References