Mailinglist Archive: opensuse (933 mails)

< Previous Next >
Re: [opensuse] IPv6 firewall
  • From: James Knott <james.knott@xxxxxxxxxx>
  • Date: Fri, 04 Jun 2010 11:36:10 -0400
  • Message-id: <4C091D6A.6020801@xxxxxxxxxx>
Adam Tauno Williams wrote:
On Thu, 2010-06-03 at 10:25 -0400, James Knott wrote:
I have been using SuSEfirewall2 for several years with IPv4. However,
IIRC, it doesn't work with IPv6, which I have recently started using.
What firewalls work with IPv6?
We abandoned all else for fwbuilder *years* ago, and it has only gotten
amazingly better. It supports iptables, IPv4/IPv6, BSD's ipfw, Cisco
IOS, etc... it will install and activate the rules across the network...
it is one *amazing* application.

<http://www.fwbuilder.org/>

Build your servers' firewall configurations and click install. In a
beautiful GUI with zero loss of flexibility.

zypper ar -cf -n 'Firewall Builder' \
http://www.fwbuilder.org/rpm/stable/opensuse-11-i586/ fwbuilder
wget http://www.fwbuilder.org/PACKAGE-GPG-KEY-fwbuilder.asc
rpm --import PACKAGE-GPG-KEY-fwbuilder.asc
zypper refresh
zypper install fwbuilder

Enjoy. I only wish other aspects of Linux administration had tools of similar
quality to fwbuilder.


I tried to install using Yast software management and get this error:

#### YaST2 conflicts list - generated 2010-06-04 11:29:43 ####

nothing provides libstdc++.so.6(GLIBCXX_3.4.11) needed by libfwbuilder-4.0.1-b29
50.suse11.2.i586

[ ] do not install fwbuilder-4.0.1-b2950.suse11.2.i586


However, libstdc++.so.6 is part of the standard C++ shared library. This is on OpenSUSE 11.0.



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >